summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-11 11:50:46 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-11 11:50:46 +0000
commit9cb8dd93e24456f1710a7c6474a53e87afaa3b75 (patch)
tree89756a4242701e42d64a2efa79149135b449679e /dev-ruby/multi_json
parentStable for amd64, wrt bug #441144 (diff)
downloadgentoo-2-9cb8dd93e24456f1710a7c6474a53e87afaa3b75.tar.gz
gentoo-2-9cb8dd93e24456f1710a7c6474a53e87afaa3b75.tar.bz2
gentoo-2-9cb8dd93e24456f1710a7c6474a53e87afaa3b75.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/ChangeLog7
-rw-r--r--dev-ruby/multi_json/multi_json-1.3.7.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-ruby/multi_json/ChangeLog b/dev-ruby/multi_json/ChangeLog
index b566e1881461..a2dfc9c11d57 100644
--- a/dev-ruby/multi_json/ChangeLog
+++ b/dev-ruby/multi_json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/multi_json
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.22 2012/08/28 05:23:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.23 2012/11/11 11:50:46 graaff Exp $
+
+*multi_json-1.3.7 (11 Nov 2012)
+
+ 11 Nov 2012; Hans de Graaff <graaff@gentoo.org> +multi_json-1.3.7.ebuild:
+ Version bump.
28 Aug 2012; Hans de Graaff <graaff@gentoo.org> -multi_json-1.0.4.ebuild,
-multi_json-1.2.0.ebuild, -multi_json-1.3.4.ebuild, -multi_json-1.3.5.ebuild:
diff --git a/dev-ruby/multi_json/multi_json-1.3.7.ebuild b/dev-ruby/multi_json/multi_json-1.3.7.ebuild
new file mode 100644
index 000000000000..3590077fd26f
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.3.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.3.7.ebuild,v 1.1 2012/11/11 11:50:46 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="http://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:2 )"
+
+ruby_add_bdepend "test? ( dev-ruby/json )"
+
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die "Unable to remove bundler."
+ rm Gemfile || die "Unable to remove bundler Gemfile."
+
+ # Provide version otherwise provided by bundler.
+ sed -i -e "s/#{MultiJson::VERSION}/${PV}/" Rakefile || die
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove best default spec since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
+}
+
+each_ruby_test() {
+ CI=true each_fakegem_test
+}