summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-03 07:52:07 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-03 07:52:07 +0000
commitd7afd2c8590cc8dbeb4f3edb7b9708ec7cccdc83 (patch)
treebbdb86d602c4c5ae1d823bebdae4e10e7b7abf00 /dev-ruby/multi_json
parentVersion bump, add python3_4 support. (diff)
downloadgentoo-2-d7afd2c8590cc8dbeb4f3edb7b9708ec7cccdc83.tar.gz
gentoo-2-d7afd2c8590cc8dbeb4f3edb7b9708ec7cccdc83.tar.bz2
gentoo-2-d7afd2c8590cc8dbeb4f3edb7b9708ec7cccdc83.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/ChangeLog7
-rw-r--r--dev-ruby/multi_json/multi_json-1.9.3.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-ruby/multi_json/ChangeLog b/dev-ruby/multi_json/ChangeLog
index b39615998d4e..1ae676208b25 100644
--- a/dev-ruby/multi_json/ChangeLog
+++ b/dev-ruby/multi_json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/multi_json
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.38 2014/04/05 23:39:34 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.39 2014/05/03 07:52:07 graaff Exp $
+
+*multi_json-1.9.3 (03 May 2014)
+
+ 03 May 2014; Hans de Graaff <graaff@gentoo.org> +multi_json-1.9.3.ebuild:
+ Version bump.
05 Apr 2014; Manuel Rüger <mrueg@gentoo.org> multi_json-1.5.0.ebuild,
multi_json-1.6.1-r1.ebuild, multi_json-1.6.1.ebuild, multi_json-1.8.4.ebuild,
diff --git a/dev-ruby/multi_json/multi_json-1.9.3.ebuild b/dev-ruby/multi_json/multi_json-1.9.3.ebuild
new file mode 100644
index 000000000000..a80fd3ac79e3
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.9.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.9.3.ebuild,v 1.1 2014/05/03 07:52:07 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="http://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:2 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json )"
+
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+ rm Gemfile || die "Unable to remove bundler Gemfile."
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove specs specific to oj since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
+ -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
+ -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
+ -e '/using one-shot parser/,/^ end/ s:^:#:' \
+ spec/multi_json_spec.rb
+
+ # Avoid simplecov which only works with ruby 1.9
+ sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
+
+ # Remove unpackaged and for our purposes unneeded coveralls
+ sed -i -e '/coveralls/d' spec/spec_helper.rb || die
+
+ # Avoid testing unpackaged adapters
+ rm spec/{gson,jr_jackson,oj}_adapter_spec.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Compiled code is not supported for jruby 1.6
+ rm spec/json_gem_adapter_spec.rb || die
+ # jr_jackson is not supported but needed for the common tests.
+ rm spec/multi_json_spec.rb || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ for t in spec/*_spec.rb; do
+ ${RUBY} -S rspec ${t} || die
+ done
+}