summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-05-18 19:07:56 +0000
committerHans de Graaff <graaff@gentoo.org>2010-05-18 19:07:56 +0000
commitb032b9f766e71e6dedb4b84b3799a121c5c8e2c2 (patch)
tree5455c106cfe24539068ac0a0b5a97de9ec49f127 /dev-ruby/net-geoip/net-geoip-0.07.ebuild
parentVersion bump. This also fixes bug #289110. Remove old. (diff)
downloadgentoo-2-b032b9f766e71e6dedb4b84b3799a121c5c8e2c2.tar.gz
gentoo-2-b032b9f766e71e6dedb4b84b3799a121c5c8e2c2.tar.bz2
gentoo-2-b032b9f766e71e6dedb4b84b3799a121c5c8e2c2.zip
Version bump. Convert to ruby-ng.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/net-geoip/net-geoip-0.07.ebuild')
-rw-r--r--dev-ruby/net-geoip/net-geoip-0.07.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/net-geoip/net-geoip-0.07.ebuild b/dev-ruby/net-geoip/net-geoip-0.07.ebuild
new file mode 100644
index 000000000000..6e47ea02c97c
--- /dev/null
+++ b/dev-ruby/net-geoip/net-geoip-0.07.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/net-geoip/net-geoip-0.07.ebuild,v 1.1 2010/05/18 19:07:56 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+IUSE=""
+
+DESCRIPTION="Ruby bindings for the GeoIP library"
+HOMEPAGE="http://www.maxmind.com/app/ruby"
+SRC_URI="http://geolite.maxmind.com/download/geoip/api/ruby/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+DEPEND="${DEPEND} >=dev-libs/geoip-1.2.1"
+RDEPEND="${RDEPEND} >=dev-libs/geoip-1.2.1"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake || die
+}
+
+each_ruby_install () {
+ emake install DESTDIR="${D}" || die
+}
+
+all_ruby_install() {
+ dodoc README TODO
+}