summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-04-04 06:46:16 +0000
committerHans de Graaff <graaff@gentoo.org>2015-04-04 06:46:16 +0000
commitc8c8bb8348f202fbd142e7a873c67bda30fae2cc (patch)
tree9f4a225bfbaa6efb5ab9519c084b03e355dfa4ec /dev-ruby/ntlm-http
parentBump hdbc-postgresql to 2.3.2.3. Drop hdbc-postgresql-2.3.2.2-r1 as it was re... (diff)
downloadgentoo-2-c8c8bb8348f202fbd142e7a873c67bda30fae2cc.tar.gz
gentoo-2-c8c8bb8348f202fbd142e7a873c67bda30fae2cc.tar.bz2
gentoo-2-c8c8bb8348f202fbd142e7a873c67bda30fae2cc.zip
Create stable candidate.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/ntlm-http')
-rw-r--r--dev-ruby/ntlm-http/ChangeLog8
-rw-r--r--dev-ruby/ntlm-http/ntlm-http-0.1.1-r1.ebuild5
-rw-r--r--dev-ruby/ntlm-http/ntlm-http-0.1.1-r2.ebuild37
3 files changed, 46 insertions, 4 deletions
diff --git a/dev-ruby/ntlm-http/ChangeLog b/dev-ruby/ntlm-http/ChangeLog
index fac1d193c3a8..ca56cb6a8624 100644
--- a/dev-ruby/ntlm-http/ChangeLog
+++ b/dev-ruby/ntlm-http/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ntlm-http
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ntlm-http/ChangeLog,v 1.10 2015/03/24 16:23:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ntlm-http/ChangeLog,v 1.11 2015/04/04 06:46:16 graaff Exp $
+
+*ntlm-http-0.1.1-r2 (04 Apr 2015)
+
+ 04 Apr 2015; Hans de Graaff <graaff@gentoo.org> ntlm-http-0.1.1-r1.ebuild,
+ +ntlm-http-0.1.1-r2.ebuild:
+ Create stable candidate.
24 Mar 2015; Hans de Graaff <graaff@gentoo.org> ntlm-http-0.1.1-r1.ebuild:
Add ruby22.
diff --git a/dev-ruby/ntlm-http/ntlm-http-0.1.1-r1.ebuild b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r1.ebuild
index e511bd3aace5..77f83df989dc 100644
--- a/dev-ruby/ntlm-http/ntlm-http-0.1.1-r1.ebuild
+++ b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r1.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ntlm-http/ntlm-http-0.1.1-r1.ebuild,v 1.4 2015/03/24 16:23:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ntlm-http/ntlm-http-0.1.1-r1.ebuild,v 1.5 2015/04/04 06:46:16 graaff Exp $
EAPI=5
-# jruby → tests fail _badly_
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_RECIPE_TEST="none"
diff --git a/dev-ruby/ntlm-http/ntlm-http-0.1.1-r2.ebuild b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..5e4a9cab6326
--- /dev/null
+++ b/dev-ruby/ntlm-http/ntlm-http-0.1.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ntlm-http/ntlm-http-0.1.1-r2.ebuild,v 1.1 2015/04/04 06:46:16 graaff Exp $
+
+EAPI=5
+
+# jruby → tests fail _badly_
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOC_SOURCES="lib README"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby/NTLM HTTP provides NTLM authentication over http"
+HOMEPAGE="http://www.mindflowsolutions.net/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+all_ruby_prepare() {
+ find . -name '*.rb' -exec sed -i -e 's:\r$::' {} +
+
+ # We can't use RUBY_PATCHES for this because we need first to convert the files
+ epatch "${FILESDIR}"/${P}+ruby-1.9.patch
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/*_test.rb
+}