summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-12-27 14:30:02 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-12-27 14:30:02 +0000
commit53091f93a3f07cd4ba03b1bed7a9a22c12293257 (patch)
tree0a97d226f245a5ce2200d6af3a11fcade531a550 /dev-ruby/parser/parser-2.2.0.ebuild
parentConvert to distutils-r1. (diff)
downloadgentoo-2-53091f93a3f07cd4ba03b1bed7a9a22c12293257.tar.gz
gentoo-2-53091f93a3f07cd4ba03b1bed7a9a22c12293257.tar.bz2
gentoo-2-53091f93a3f07cd4ba03b1bed7a9a22c12293257.zip
Version bump. Remove old.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/parser/parser-2.2.0.ebuild')
-rw-r--r--dev-ruby/parser/parser-2.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/parser/parser-2.2.0.ebuild b/dev-ruby/parser/parser-2.2.0.ebuild
new file mode 100644
index 000000000000..258f9cab9d74
--- /dev/null
+++ b/dev-ruby/parser/parser-2.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parser/parser-2.2.0.ebuild,v 1.1 2014/12/27 14:30:02 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_VERSION="${PV/_pre/.pre.}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A production-ready Ruby parser written in pure Ruby"
+HOMEPAGE="https://github.com/whitequark/parser"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/minitest:5
+ dev-ruby/racc
+ dev-ruby/cliver )"
+ruby_add_rdepend "dev-ruby/ast
+ dev-ruby/slop:3"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/simplecov/,+35d" test/helper.rb || die
+}