summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-02 15:15:44 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-02 15:15:44 +0000
commit99070089491f28e1491c218f5e5c61a3a67f5a98 (patch)
tree9c1effb53163742c65982284d195f08d85e73bca /dev-ruby/patron/patron-0.4.11.ebuild
parentVersion bump. (diff)
downloadgentoo-2-99070089491f28e1491c218f5e5c61a3a67f5a98.tar.gz
gentoo-2-99070089491f28e1491c218f5e5c61a3a67f5a98.tar.bz2
gentoo-2-99070089491f28e1491c218f5e5c61a3a67f5a98.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/patron/patron-0.4.11.ebuild')
-rw-r--r--dev-ruby/patron/patron-0.4.11.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/patron/patron-0.4.11.ebuild b/dev-ruby/patron/patron-0.4.11.ebuild
new file mode 100644
index 000000000000..c0c9e7c5f5dd
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.11.ebuild,v 1.1 2011/01/02 15:15:44 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+#ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+DEPEND="${DEPEND} net-misc/curl"
+RDEPEND="${RDEPEND} net-misc/curl"
+
+# Tests require a live web service that is not included in the distribution.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron || die
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}