summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-03 08:27:48 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-03 08:27:48 +0000
commitb144c94a5ceeae06b31169c1c3e9a4bce46b7cb2 (patch)
treefc0404673d485d94adc4ec4642cce7721efc8baf /dev-ruby/patron
parentUse pkg-config for cfitsio wrt bug 339460. Thanks to Diego for the report. Dr... (diff)
downloadgentoo-2-b144c94a5ceeae06b31169c1c3e9a4bce46b7cb2.tar.gz
gentoo-2-b144c94a5ceeae06b31169c1c3e9a4bce46b7cb2.tar.bz2
gentoo-2-b144c94a5ceeae06b31169c1c3e9a4bce46b7cb2.zip
Install VERSION.yml as some code depends on it.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/ChangeLog7
-rw-r--r--dev-ruby/patron/patron-0.4.9-r1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/patron/ChangeLog b/dev-ruby/patron/ChangeLog
index 96dd66f9bd4d..20603da82d6a 100644
--- a/dev-ruby/patron/ChangeLog
+++ b/dev-ruby/patron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/patron
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.3 2010/09/19 07:42:50 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.4 2010/10/03 08:27:48 graaff Exp $
+
+*patron-0.4.9-r1 (03 Oct 2010)
+
+ 03 Oct 2010; Hans de Graaff <graaff@gentoo.org> +patron-0.4.9-r1.ebuild:
+ Install VERSION.yml as some code depends on it.
*patron-0.4.9 (19 Sep 2010)
diff --git a/dev-ruby/patron/patron-0.4.9-r1.ebuild b/dev-ruby/patron/patron-0.4.9-r1.ebuild
new file mode 100644
index 000000000000..1a9bfb96244b
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.9-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.9-r1.ebuild,v 1.1 2010/10/03 08:27:48 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION.yml"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/jeweler )"
+#ruby_add_bdepend "test? ( dev-ruby/jeweler dev-ruby/rspec )"
+
+DEPEND="${DEPEND} net-misc/curl"
+RDEPEND="${RDEPEND} net-misc/curl"
+
+# Tests require a live web service that is not included in the distribution.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron || die
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}