summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-15 08:08:53 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-15 08:08:53 +0000
commit0f5e5831b23780ba6550ee2fa56d10cf70fc0c88 (patch)
treebdeca44e63801c87e35ad6a7606349fd58a60daf /dev-ruby/pkg-config
parentBump, adds support for nmap and iputils. Fix launching utilities in /sbin and... (diff)
downloadgentoo-2-0f5e5831b23780ba6550ee2fa56d10cf70fc0c88.tar.gz
gentoo-2-0f5e5831b23780ba6550ee2fa56d10cf70fc0c88.tar.bz2
gentoo-2-0f5e5831b23780ba6550ee2fa56d10cf70fc0c88.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/pkg-config')
-rw-r--r--dev-ruby/pkg-config/ChangeLog7
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.1.3.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/pkg-config/ChangeLog b/dev-ruby/pkg-config/ChangeLog
index de0ae52ad811..1f84f1b39f07 100644
--- a/dev-ruby/pkg-config/ChangeLog
+++ b/dev-ruby/pkg-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/pkg-config
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/ChangeLog,v 1.6 2012/03/18 15:23:01 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/ChangeLog,v 1.7 2012/04/15 08:08:53 graaff Exp $
+
+*pkg-config-1.1.3 (15 Apr 2012)
+
+ 15 Apr 2012; Hans de Graaff <graaff@gentoo.org> +pkg-config-1.1.3.ebuild:
+ Version bump.
18 Mar 2012; Brent Baude <ranger@gentoo.org> pkg-config-1.1.2.ebuild:
Marking pkg-config-1.1.2 ~ppc64 for bug 371353
diff --git a/dev-ruby/pkg-config/pkg-config-1.1.3.ebuild b/dev-ruby/pkg-config/pkg-config-1.1.3.ebuild
new file mode 100644
index 000000000000..c4637c100a68
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/pkg-config-1.1.3.ebuild,v 1.1 2012/04/15 08:08:53 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+# Requires rcairo to be installed.
+RESTRICT="test"
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}