summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-05-26 17:28:40 +0000
committerNaohiro Aota <naota@gentoo.org>2011-05-26 17:28:40 +0000
commitab5447b5b50dc3a21e987cd6fedd46d1b0302833 (patch)
tree934f17766674b601038de10eada1164edb967c89 /dev-ruby/pkg-config
parentRemove app-cdr/xorriso as it is just bundled dev-libs/libisoburn package. (diff)
downloadgentoo-2-ab5447b5b50dc3a21e987cd6fedd46d1b0302833.tar.gz
gentoo-2-ab5447b5b50dc3a21e987cd6fedd46d1b0302833.tar.bz2
gentoo-2-ab5447b5b50dc3a21e987cd6fedd46d1b0302833.zip
New package dev-ruby/pkg-config. Dependency for bug #345721
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/pkg-config')
-rw-r--r--dev-ruby/pkg-config/ChangeLog10
-rw-r--r--dev-ruby/pkg-config/files/pkg-config-1.1.1-Manifest.txt8
-rw-r--r--dev-ruby/pkg-config/metadata.xml8
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.1.1.ebuild26
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/ChangeLog b/dev-ruby/pkg-config/ChangeLog
new file mode 100644
index 000000000000..0a84a39ca836
--- /dev/null
+++ b/dev-ruby/pkg-config/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/pkg-config
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/ChangeLog,v 1.1 2011/05/26 17:28:40 naota Exp $
+
+*pkg-config-1.1.1 (26 May 2011)
+
+ 26 May 2011; Naohiro Aota <naota@gentoo.org> +pkg-config-1.1.1.ebuild,
+ +files/pkg-config-1.1.1-Manifest.txt, +metadata.xml:
+ New package dev-ruby/pkg-config. Dependency for bug #345721
+
diff --git a/dev-ruby/pkg-config/files/pkg-config-1.1.1-Manifest.txt b/dev-ruby/pkg-config/files/pkg-config-1.1.1-Manifest.txt
new file mode 100644
index 000000000000..f4cd9be285aa
--- /dev/null
+++ b/dev-ruby/pkg-config/files/pkg-config-1.1.1-Manifest.txt
@@ -0,0 +1,8 @@
+LGPL-2.1
+NEWS
+README.rdoc
+Rakefile
+extconf.rb
+lib/pkg-config.rb
+test/run-test.rb
+test/test_pkg_config.rb
diff --git a/dev-ruby/pkg-config/metadata.xml b/dev-ruby/pkg-config/metadata.xml
new file mode 100644
index 000000000000..59cfa35b8816
--- /dev/null
+++ b/dev-ruby/pkg-config/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<maintainer>
+ <email>naota@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/pkg-config/pkg-config-1.1.1.ebuild b/dev-ruby/pkg-config/pkg-config-1.1.1.ebuild
new file mode 100644
index 000000000000..89b0984a4635
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/pkg-config-1.1.1.ebuild,v 1.1 2011/05/26 17:28:40 naota Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS README.rdoc"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+all_ruby_prepare() {
+ cp "${FILESDIR}"/${PN}-1.1.1-Manifest.txt Manifest.txt || die
+}