summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-02-20 06:40:11 +0000
committerHans de Graaff <graaff@gentoo.org>2014-02-20 06:40:11 +0000
commit8ae89e54f5ae18f87b6e9a4789be53de4a9ca4da (patch)
treed40e369820fa4f86cbc3a826be86a5d010db634f /dev-ruby/polyglot/polyglot-0.3.4.ebuild
parentVersion bump. (diff)
downloadgentoo-2-8ae89e54f5ae18f87b6e9a4789be53de4a9ca4da.tar.gz
gentoo-2-8ae89e54f5ae18f87b6e9a4789be53de4a9ca4da.tar.bz2
gentoo-2-8ae89e54f5ae18f87b6e9a4789be53de4a9ca4da.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/polyglot/polyglot-0.3.4.ebuild')
-rw-r--r--dev-ruby/polyglot/polyglot-0.3.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/polyglot/polyglot-0.3.4.ebuild b/dev-ruby/polyglot/polyglot-0.3.4.ebuild
new file mode 100644
index 000000000000..e9c65bd75800
--- /dev/null
+++ b/dev-ruby/polyglot/polyglot-0.3.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/polyglot-0.3.4.ebuild,v 1.1 2014/02/20 06:40:11 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 ruby21 jruby rbx"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Polyglot provides support for fully-custom DSLs."
+HOMEPAGE="http://polyglot.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ # jruby has trouble parsing this metadata and there are no dependencies.
+ rm ../metadata || die
+}