summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-05-20 06:29:53 +0000
committerHans de Graaff <graaff@gentoo.org>2012-05-20 06:29:53 +0000
commit4313cc2f8bac674318c30bff3faa1c248e174b16 (patch)
tree4473be3c919a6f5b569a9f7ac3c5ee9289b34adf /dev-ruby/racc
parentold (diff)
downloadgentoo-2-4313cc2f8bac674318c30bff3faa1c248e174b16.tar.gz
gentoo-2-4313cc2f8bac674318c30bff3faa1c248e174b16.tar.bz2
gentoo-2-4313cc2f8bac674318c30bff3faa1c248e174b16.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/racc')
-rw-r--r--dev-ruby/racc/ChangeLog7
-rw-r--r--dev-ruby/racc/racc-1.4.8.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/dev-ruby/racc/ChangeLog b/dev-ruby/racc/ChangeLog
index 43ec1385797a..fcd62328460d 100644
--- a/dev-ruby/racc/ChangeLog
+++ b/dev-ruby/racc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/racc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.67 2012/02/05 20:48:55 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.68 2012/05/20 06:29:53 graaff Exp $
+
+*racc-1.4.8 (20 May 2012)
+
+ 20 May 2012; Hans de Graaff <graaff@gentoo.org> +racc-1.4.8.ebuild:
+ Version bump.
05 Feb 2012; Markus Meier <maekke@gentoo.org> racc-1.4.7.ebuild:
add ~arm, bug #332593
diff --git a/dev-ruby/racc/racc-1.4.8.ebuild b/dev-ruby/racc/racc-1.4.8.ebuild
new file mode 100644
index 000000000000..9e61042a41fd
--- /dev/null
+++ b/dev-ruby/racc/racc-1.4.8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.8.ebuild,v 1.1 2012/05/20 06:29:53 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ree18 ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A LALR(1) parser generator for Ruby"
+HOMEPAGE="http://www.loveruby.net/en/racc.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+ruby_add_bdepend "dev-ruby/rake
+ doc? ( dev-ruby/hoe )"
+
+all_ruby_prepare() {
+ sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
+
+ # Avoid depending on rake-compiler since we don't use it to compile
+ # the extension.
+ sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
+ sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
+
+ # Avoid isolation since dependencies are not properly declared.
+ sed -i -e 's/, :isolate//' Rakefile || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ ${RUBY} -Cext/racc extconf.rb || die
+ ;;
+ esac
+}
+
+each_ruby_compile() {
+ case ${RUBY} in
+ *jruby)
+ einfo "Under JRuby, racc cannot use the shared object parser, so instead"
+ einfo "you have to rely on the pure Ruby implementation."
+ ;;
+ *)
+ emake -Cext/racc
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ewarn "Using JRuby 1.5.2 the tests are currently badly broken,"
+ ewarn "so they are disabled until a new racc or a new JRuby is"
+ ewarn "released."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r rdoc
+
+ docinto examples
+ dodoc -r sample
+}