summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-07-25 03:05:31 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-07-25 03:05:31 +0000
commit4253df243ea3632ce2d11f7bf11cd0300dc0430f (patch)
tree5959156ca1923332fb884fb56aabff22dd0bcd28 /dev-ruby/rack-mount
parentBuild on newer systemd by using pkg-config to grab right library. (diff)
downloadgentoo-2-4253df243ea3632ce2d11f7bf11cd0300dc0430f.tar.gz
gentoo-2-4253df243ea3632ce2d11f7bf11cd0300dc0430f.tar.bz2
gentoo-2-4253df243ea3632ce2d11f7bf11cd0300dc0430f.zip
Add ruby20, ruby21 targets.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/rack-mount')
-rw-r--r--dev-ruby/rack-mount/ChangeLog8
-rw-r--r--dev-ruby/rack-mount/files/rack-mount-fix-ruby20.patch26
-rw-r--r--dev-ruby/rack-mount/rack-mount-0.8.3-r2.ebuild30
3 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/rack-mount/ChangeLog b/dev-ruby/rack-mount/ChangeLog
index ce4c59ab9ff7..0230b273554b 100644
--- a/dev-ruby/rack-mount/ChangeLog
+++ b/dev-ruby/rack-mount/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rack-mount
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-mount/ChangeLog,v 1.29 2014/05/21 01:45:01 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-mount/ChangeLog,v 1.30 2014/07/25 03:05:31 mrueg Exp $
+
+*rack-mount-0.8.3-r2 (25 Jul 2014)
+
+ 25 Jul 2014; Manuel Rüger <mrueg@gentoo.org>
+ +files/rack-mount-fix-ruby20.patch, +rack-mount-0.8.3-r2.ebuild:
+ Add ruby20, ruby21 targets.
21 May 2014; Manuel Rüger <mrueg@gentoo.org> rack-mount-0.8.3-r1.ebuild:
Remove ruby18 target.
diff --git a/dev-ruby/rack-mount/files/rack-mount-fix-ruby20.patch b/dev-ruby/rack-mount/files/rack-mount-fix-ruby20.patch
new file mode 100644
index 000000000000..f1e37faa21d6
--- /dev/null
+++ b/dev-ruby/rack-mount/files/rack-mount-fix-ruby20.patch
@@ -0,0 +1,26 @@
+From 42e7ae47c2dac2d98272ac99239e40bd59398891 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <v.ondruch@tiscali.cz>
+Date: Tue, 9 Apr 2013 11:12:02 +0300
+Subject: [PATCH] Fix Ruby 2.0.0 compatibility
+
+#respond_to? now exclude protected methods.
+---
+ lib/rack/mount/multimap.rb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/rack/mount/multimap.rb b/lib/rack/mount/multimap.rb
+index 6b773e2..b88630b 100644
+--- a/lib/rack/mount/multimap.rb
++++ b/lib/rack/mount/multimap.rb
+@@ -125,7 +125,7 @@ def update_container(key)
+ end
+
+ def iterate_over_container(container)
+- if container.respond_to?(:each_container_with_default)
++ if container.respond_to?(:each_container_with_default, true)
+ container.each_container_with_default do |value|
+ yield value
+ end
+--
+1.9.3
+
diff --git a/dev-ruby/rack-mount/rack-mount-0.8.3-r2.ebuild b/dev-ruby/rack-mount/rack-mount-0.8.3-r2.ebuild
new file mode 100644
index 000000000000..00cf1f483b59
--- /dev/null
+++ b/dev-ruby/rack-mount/rack-mount-0.8.3-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-mount/rack-mount-0.8.3-r2.ebuild,v 1.1 2014/07/25 03:05:31 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="A stackable dynamic tree based Rack router."
+HOMEPAGE="https://github.com/josh/rack-mount"
+SRC_URI="https://github.com/josh/rack-mount/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="josh-${PN}-*"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rack-1.0.0"
+
+RUBY_PATCHES=( ${PN}-fix-ruby20.patch )
+
+all_ruby_prepare() {
+ # Avoid fragile test depending on hash ordering.
+ sed -i -e '/foo=1&bar=2/ s:^:#:' test/test_utils.rb || die
+}