summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-24 08:03:02 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-24 08:03:02 +0000
commit6529555779337e3b0ff7530241c9164be93512d5 (patch)
tree95a446430a1192741f01f15d915eccd859d07378 /dev-ruby/rack
parentVersion bump. (diff)
downloadgentoo-2-6529555779337e3b0ff7530241c9164be93512d5.tar.gz
gentoo-2-6529555779337e3b0ff7530241c9164be93512d5.tar.bz2
gentoo-2-6529555779337e3b0ff7530241c9164be93512d5.zip
Version bump. Make sure only the latest testing version installs rackup.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rack')
-rw-r--r--dev-ruby/rack/ChangeLog9
-rw-r--r--dev-ruby/rack/rack-1.2.4-r2.ebuild69
-rw-r--r--dev-ruby/rack/rack-1.3.5.ebuild56
3 files changed, 133 insertions, 1 deletions
diff --git a/dev-ruby/rack/ChangeLog b/dev-ruby/rack/ChangeLog
index 3739838ed0ae..6e169ea8bb6b 100644
--- a/dev-ruby/rack/ChangeLog
+++ b/dev-ruby/rack/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.63 2011/12/17 14:53:47 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.64 2011/12/24 08:03:02 graaff Exp $
+
+*rack-1.3.5 (24 Dec 2011)
+*rack-1.2.4-r2 (24 Dec 2011)
+
+ 24 Dec 2011; Hans de Graaff <graaff@gentoo.org> +rack-1.2.4-r2.ebuild,
+ +rack-1.3.5.ebuild:
+ Version bump. Make sure only the latest testing version installs rackup.
17 Dec 2011; Hans de Graaff <graaff@gentoo.org> rack-1.2.4-r1.ebuild:
Avoid broken specs for ruby19. These appear to be related to changes in newer
diff --git a/dev-ruby/rack/rack-1.2.4-r2.ebuild b/dev-ruby/rack/rack-1.2.4-r2.ebuild
new file mode 100644
index 000000000000..81a42b4cd6c9
--- /dev/null
+++ b/dev-ruby/rack/rack-1.2.4-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.2.4-r2.ebuild,v 1.1 2011/12/24 08:03:02 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README SPEC"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all. We do add the fcgi dependency because
+# that spec isn't optional.
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/ruby-fcgi )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.0-r1:0"
+
+#USE_RUBY=ruby19 \
+# ruby_add_bdepend "ruby_targets_ruby19 test" '=dev-ruby/test-unit-1*'
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
+
+ # Add missing require for Mutex use. This may show up in the tests
+ # depending on load order.
+ sed -i -e '1 irequire "thread"' lib/rack/lock.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19)
+ # Avoid failing encoding-related specs, most likely due to
+ # changes in handling of encodings in newer ruby 19
+ # versions.
+ sed -i -e '/escape non-UTF8 strings/,/end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/escape html entities in unicode strings/,/end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/escape html entities even on MRI/,/^ end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/accept params and build multipart encoded params/,/^ end/ s:^:#:' test/spec_mock.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.3.5.ebuild b/dev-ruby/rack/rack-1.3.5.ebuild
new file mode 100644
index 000000000000..9c16bcf0203f
--- /dev/null
+++ b/dev-ruby/rack/rack-1.3.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.3.5.ebuild,v 1.1 2011/12/24 08:03:02 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README.rdoc SPEC"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all. We do add the fcgi dependency because
+# that spec isn't optional.
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/ruby-fcgi )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.0-r1:0 !<dev-ruby/rack-1.2.4-r2:1.2"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Avoid two failing tests due to bugs in jruby that should
+ # be solved in 1.6.5 or 1.7.
+ rm test/spec_deflater.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}