summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-09-04 06:30:17 +0000
committerHans de Graaff <graaff@gentoo.org>2009-09-04 06:30:17 +0000
commit2aea67848f7ce98083cf9d4952bd0b81459409b4 (patch)
treed546b5320ebc8cdb3c029693bcb67942e7be7cab /dev-ruby/rails
parentVersion bump. (diff)
downloadgentoo-2-2aea67848f7ce98083cf9d4952bd0b81459409b4.tar.gz
gentoo-2-2aea67848f7ce98083cf9d4952bd0b81459409b4.tar.bz2
gentoo-2-2aea67848f7ce98083cf9d4952bd0b81459409b4.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.3.4.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 92641c6f5dda..a9d0d594175f 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.142 2009/08/16 14:31:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.143 2009/09/04 06:30:17 graaff Exp $
+
+*rails-2.3.4 (04 Sep 2009)
+
+ 04 Sep 2009; Hans de Graaff <graaff@gentoo.org> +rails-2.3.4.ebuild:
+ Version bump: fix security issues reported in #283396.
16 Aug 2009; Raúl Porcel <armin76@gentoo.org> rails-2.3.3.ebuild:
Add ~ia64 wrt #279123
diff --git a/dev-ruby/rails/rails-2.3.4.ebuild b/dev-ruby/rails/rails-2.3.4.ebuild
new file mode 100644
index 000000000000..fef5987b0198
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.4.ebuild,v 1.1 2009/09/04 06:30:17 graaff Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="fastcgi"
+DEPEND=">=dev-lang/ruby-1.8.6
+ >=app-admin/eselect-rails-0.15
+ >=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-2.3.4
+ ~dev-ruby/activeresource-2.3.4
+ ~dev-ruby/activesupport-2.3.4
+ ~dev-ruby/actionmailer-2.3.4
+ ~dev-ruby/actionpack-2.3.4"
+
+RDEPEND="${DEPEND}
+ fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )
+ >=dev-ruby/rubygems-1.3.1"
+
+src_install() {
+ gems_src_install
+ # Rename slotted files that may clash so that eselect can handle
+ # them
+ mv "${D}/usr/bin/rails" "${D}/usr/bin/rails-${PV}"
+ sed -i -e "s/>= 0/${PV}/" "${D}/usr/bin/rails-${PV}"
+ mv "${D}/${GEMSDIR}/bin/rails" "${D}/${GEMSDIR}/bin/rails-${PV}"
+}
+
+pkg_postinst() {
+ einfo "To select between slots of rails, use:"
+ einfo "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}