summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-12-17 10:46:54 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-12-17 10:46:54 +0000
commit11b3dcbb56482f89cca4ee5da30f61286fadbe93 (patch)
tree3f2b7c5167484dea34b59c29ad9cfbdfa26ae5a2 /dev-ruby/rake-compiler
parentAdd ~alpha/~ia64/~s390/~sh/~sparc wrt #453782 (diff)
downloadgentoo-2-11b3dcbb56482f89cca4ee5da30f61286fadbe93.tar.gz
gentoo-2-11b3dcbb56482f89cca4ee5da30f61286fadbe93.tar.bz2
gentoo-2-11b3dcbb56482f89cca4ee5da30f61286fadbe93.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/rake-compiler')
-rw-r--r--dev-ruby/rake-compiler/ChangeLog7
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.9.2.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/rake-compiler/ChangeLog b/dev-ruby/rake-compiler/ChangeLog
index 5ddd82351737..59d08040ceda 100644
--- a/dev-ruby/rake-compiler/ChangeLog
+++ b/dev-ruby/rake-compiler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rake-compiler
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.63 2013/10/06 09:50:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.64 2013/12/17 10:46:54 mrueg Exp $
+
+*rake-compiler-0.9.2 (17 Dec 2013)
+
+ 17 Dec 2013; Manuel Rüger <mrueg@gentoo.org> +rake-compiler-0.9.2.ebuild:
+ Version bump.
06 Oct 2013; Hans de Graaff <graaff@gentoo.org> rake-compiler-0.9.1.ebuild:
Add ruby20.
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.9.2.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.9.2.ebuild
new file mode 100644
index 000000000000..9e3640b6738d
--- /dev/null
+++ b/dev-ruby/rake-compiler/rake-compiler-0.9.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.9.2.ebuild,v 1.1 2013/12/17 10:46:54 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
+HOMEPAGE="http://github.com/luislavena/rake-compiler"
+LICENSE="MIT"
+
+SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+RUBY_S="luislavena-${PN}-*"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rake"
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+USE_RUBY="ruby18 ruby19" ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19|*jruby)
+ # Remove this task so that it won't load on Ruby 1.9 and JRuby
+ # that lack the package_task file. It is, though, needed for the
+ # tests
+ rm tasks/gem.rake || die
+ # Remove specs aimed at a C-compiling ruby implementation.
+ rm spec/lib/rake/extensiontask_spec.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ ruby-ng_rspec
+
+ # Skip cucumber for jruby (not supported) and ruby20 (not ready yet)
+ case ${RUBY} in
+ *ruby18|*ruby19)
+ ruby-ng_cucumber
+ ;;
+ esac
+}