summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-11-25 11:57:13 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-11-25 11:57:13 +0000
commit0174b5d6652f9cad53954f14525b4c1f1898e4dc (patch)
tree7e1bd50e58622b0505f4c21e78f8a15f755eb137 /dev-ruby/rake
parentDrop jruby target. (diff)
downloadgentoo-2-0174b5d6652f9cad53954f14525b4c1f1898e4dc.tar.gz
gentoo-2-0174b5d6652f9cad53954f14525b4c1f1898e4dc.tar.bz2
gentoo-2-0174b5d6652f9cad53954f14525b4c1f1898e4dc.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/rake')
-rw-r--r--dev-ruby/rake/ChangeLog7
-rw-r--r--dev-ruby/rake/rake-10.4.0.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/rake/ChangeLog b/dev-ruby/rake/ChangeLog
index e5db5fa86e28..6869317c51cd 100644
--- a/dev-ruby/rake/ChangeLog
+++ b/dev-ruby/rake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rake
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake/ChangeLog,v 1.159 2014/11/25 11:39:21 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake/ChangeLog,v 1.160 2014/11/25 11:57:13 mrueg Exp $
+
+*rake-10.4.0 (25 Nov 2014)
+
+ 25 Nov 2014; Manuel Rüger <mrueg@gentoo.org> +rake-10.4.0.ebuild:
+ Version bump.
25 Nov 2014; Manuel Rüger <mrueg@gentoo.org> rake-0.9.6-r1.ebuild,
rake-0.9.6.ebuild, rake-10.3.2.ebuild:
diff --git a/dev-ruby/rake/rake-10.4.0.ebuild b/dev-ruby/rake/rake-10.4.0.ebuild
new file mode 100644
index 000000000000..3e6f6578f34e
--- /dev/null
+++ b/dev-ruby/rake/rake-10.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake/rake-10.4.0.ebuild,v 1.1 2014/11/25 11:57:13 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="Make-like scripting in Ruby"
+HOMEPAGE="https://github.com/jimweirich/rake"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND+=" app-arch/gzip"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.4 )"
+
+all_ruby_prepare() {
+ # Decompress the file. The compressed version has errors, ignore them.
+ zcat doc/rake.1.gz > doc/rake.1
+}
+
+all_ruby_compile() {
+ if use doc; then
+ rdoc --title "Rake - Ruby Make" --main README.rdoc --out html lib *.rdoc doc/*/*.rdoc || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'gem "minitest", "~>5.4"; require "minitest/autorun"; Dir["test/test_*.rb"].each{|f| require f}' || die
+}
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper rake
+
+ if use doc; then
+ pushd html
+ dohtml -r *
+ popd
+ fi
+
+ doman doc/rake.1
+
+ newbashcomp "${FILESDIR}"/rake.bash-completion ${PN}
+}