summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-28 07:40:47 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-28 07:40:47 +0000
commit9a9242a2f37463330e1cdc1e057293d0f777a8fa (patch)
treed55d00caf1a764842428f632785187977d66853e /dev-ruby/rdoc
parentUpdated with some minor QA fixes for bug 349458. (diff)
downloadgentoo-2-9a9242a2f37463330e1cdc1e057293d0f777a8fa.tar.gz
gentoo-2-9a9242a2f37463330e1cdc1e057293d0f777a8fa.tar.bz2
gentoo-2-9a9242a2f37463330e1cdc1e057293d0f777a8fa.zip
Fix include path for script, thanks for James le Cuirot for the patch.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rdoc')
-rw-r--r--dev-ruby/rdoc/ChangeLog8
-rw-r--r--dev-ruby/rdoc/files/rdoc-3.0.1-bin-require.patch20
-rw-r--r--dev-ruby/rdoc/rdoc-3.0.1-r1.ebuild74
3 files changed, 101 insertions, 1 deletions
diff --git a/dev-ruby/rdoc/ChangeLog b/dev-ruby/rdoc/ChangeLog
index 3e4a407459f2..0c7822a06b75 100644
--- a/dev-ruby/rdoc/ChangeLog
+++ b/dev-ruby/rdoc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rdoc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/ChangeLog,v 1.40 2010/12/27 18:38:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/ChangeLog,v 1.41 2010/12/28 07:40:47 graaff Exp $
+
+*rdoc-3.0.1-r1 (28 Dec 2010)
+
+ 28 Dec 2010; Hans de Graaff <graaff@gentoo.org> +rdoc-3.0.1-r1.ebuild,
+ +files/rdoc-3.0.1-bin-require.patch:
+ Fix include path for script, thanks for James le Cuirot for the patch.
27 Dec 2010; Hans de Graaff <graaff@gentoo.org> rdoc-2.5.11.ebuild:
Drop ruby19 support to create a stable candidate.
diff --git a/dev-ruby/rdoc/files/rdoc-3.0.1-bin-require.patch b/dev-ruby/rdoc/files/rdoc-3.0.1-bin-require.patch
new file mode 100644
index 000000000000..5159125c85fa
--- /dev/null
+++ b/dev-ruby/rdoc/files/rdoc-3.0.1-bin-require.patch
@@ -0,0 +1,20 @@
+Make sure the right version of the code is loaded. Without this the
+rdoc version bundled with ruby is always loaded instead. Reported
+upstream but won't be fixed because rubygems has slightly different
+behavior.
+
+http://rubyforge.org/tracker/index.php?func=detail&aid=28758&group_id=627&atid=2472
+
+
+Index: trunk/bin/rdoc
+===================================================================
+--- trunk/bin/rdoc (revision 650)
++++ trunk/bin/rdoc (working copy)
+@@ -8,6 +8,7 @@
+ #
+ # $Revision: 1.1 $
+
++$:.unshift(File.dirname(__FILE__) + '/../lib') unless $:.include?(File.dirname(__FILE__) + '/../lib')
+ require 'rdoc/rdoc'
+
+ begin
diff --git a/dev-ruby/rdoc/rdoc-3.0.1-r1.ebuild b/dev-ruby/rdoc/rdoc-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..361be1d949cd
--- /dev/null
+++ b/dev-ruby/rdoc/rdoc-3.0.1-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/rdoc-3.0.1-r1.ebuild,v 1.1 2010/12/28 07:40:47 graaff Exp $
+
+EAPI=3
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt RI.txt"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
+HOMEPAGE="http://rubyforge.org/projects/rdoc/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/hoe-2.5.0 )
+ test? (
+ >=dev-ruby/hoe-2.5.0
+ dev-ruby/minitest
+ )"
+
+# This ebuild replaces rdoc in ruby-1.9.2 and later.
+# ruby 1.8.6 is no longer supported.
+RDEPEND="${RDEPEND}
+ ruby_targets_ruby19? (
+ >=dev-lang/ruby-1.9.2
+ )
+ ruby_targets_ruby18? (
+ >=dev-lang/ruby-1.8.7
+ )"
+
+all_ruby_prepare() {
+ # Other packages also have use for a nonexistent directory, bug 321059
+ sed -i -e 's#/nonexistent#/nonexistent_rdoc_tests#g' test/test_rdoc*.rb || die
+
+ epatch "${FILESDIR}/${P}-bin-require.patch"
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Remove tests that will fail due to a bug in JRuby affecting
+ # Dir.mktmpdir: http://jira.codehaus.org/browse/JRUBY-4082
+ rm test/test_rdoc_options.rb test/test_rdoc_rdoc.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for bin in rdoc ri; do
+ ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
+
+ if use ruby_targets_ruby19; then
+ ruby_fakegem_binwrapper $bin /usr/bin/${bin}19
+ sed -i -e "1s/env ruby/ruby19/" \
+ "${ED}/usr/bin/${bin}19" || die
+ fi
+ done
+}