summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2007-12-27 08:09:44 +0000
committerHans de Graaff <graaff@gentoo.org>2007-12-27 08:09:44 +0000
commit200449234b2eec381fcb7ebdcc274c97341c064e (patch)
treedbfd17b3c8b9a95200ffac502abe8944ad5d11eb /dev-ruby/rmagick
parentunp version bump (diff)
downloadgentoo-2-200449234b2eec381fcb7ebdcc274c97341c064e.tar.gz
gentoo-2-200449234b2eec381fcb7ebdcc274c97341c064e.tar.bz2
gentoo-2-200449234b2eec381fcb7ebdcc274c97341c064e.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-ruby/rmagick')
-rw-r--r--dev-ruby/rmagick/ChangeLog13
-rw-r--r--dev-ruby/rmagick/files/digest-rmagick-1.15.123
-rw-r--r--dev-ruby/rmagick/rmagick-1.15.12.ebuild76
3 files changed, 91 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index e7b97af21512..f13bd18456fb 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.85 2007/12/19 22:17:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.86 2007/12/27 08:09:44 graaff Exp $
+
+*rmagick-1.15.12 (27 Dec 2007)
+
+ 27 Dec 2007; Hans de Graaff <graaff@gentoo.org> +rmagick-1.15.12.ebuild:
+ Version bump:
+ * Fix bug #16221, starting with ImageMagick 6.3.2,
+ get_exif_by_entry/number returns empty array/hash when no
+ arguments are specified, even though the image has EXIF
+ data (bug report from Paul Clegg)
+ * Fix bug #16449, Image#store_pixels removes opacity channel
+ (bug report from Hans de Graaff)
*rmagick-1.15.11 (19 Dec 2007)
diff --git a/dev-ruby/rmagick/files/digest-rmagick-1.15.12 b/dev-ruby/rmagick/files/digest-rmagick-1.15.12
new file mode 100644
index 000000000000..acdb893be752
--- /dev/null
+++ b/dev-ruby/rmagick/files/digest-rmagick-1.15.12
@@ -0,0 +1,3 @@
+MD5 20250d567b49615051b7345cd4f0e56d RMagick-1.15.12.tar.bz2 974608
+RMD160 b670ebfeac263b51110b29cc616fc0f2b2657543 RMagick-1.15.12.tar.bz2 974608
+SHA256 b7f3441aa2810f91d5619aebd203f76fe623a7a272c269e456900e3dad18d3af RMagick-1.15.12.tar.bz2 974608
diff --git a/dev-ruby/rmagick/rmagick-1.15.12.ebuild b/dev-ruby/rmagick/rmagick-1.15.12.ebuild
new file mode 100644
index 000000000000..defdf0eb17fc
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-1.15.12.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.15.12.ebuild,v 1.1 2007/12/27 08:09:44 graaff Exp $
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/29786/RMagick-${PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+DEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.0"
+
+S=${WORKDIR}/RMagick-${PV}
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+pkg_setup() {
+ if built_with_use --missing false media-gfx/imagemagick hdri ; then
+ eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
+ die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ fi
+}
+
+# Using a custom src_compile instead of the ruby one because the ruby
+# one gets confused by an additional setup.rb that should not be used
+# here.
+src_compile() {
+ myconf="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ myconf="${myconf} --disable-htmldoc --enable-allow-example-errors"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-ruby=${RUBY} \
+ ${myconf} \
+ "$@" || die "econf failed"
+
+ ruby_emake "$@" || die
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step.
+src_install() {
+ RUBY_ECONF="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ ${RUBY} setup.rb config --prefix="${D}/usr" "$@" \
+ ${RUBY_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix="${D}" "$@" \
+ ${RUBY_ECONF} || die "setup.rb install failed"
+
+ cd "${S}"
+ dodoc ChangeLog README.html README-Mac-OSX.txt README.txt
+}