summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-01-31 06:31:06 +0000
committerHans de Graaff <graaff@gentoo.org>2008-01-31 06:31:06 +0000
commit4f08cc5f3796f64f1368a142e11f8c3315d7430e (patch)
tree5efd8bea13179f3d46c560cefcc35b4fce27484f /dev-ruby/rmagick
parentClean up. (diff)
downloadgentoo-2-4f08cc5f3796f64f1368a142e11f8c3315d7430e.tar.gz
gentoo-2-4f08cc5f3796f64f1368a142e11f8c3315d7430e.tar.bz2
gentoo-2-4f08cc5f3796f64f1368a142e11f8c3315d7430e.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-ruby/rmagick')
-rw-r--r--dev-ruby/rmagick/ChangeLog8
-rw-r--r--dev-ruby/rmagick/files/digest-rmagick-2.2.03
-rw-r--r--dev-ruby/rmagick/rmagick-2.2.0.ebuild66
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index dfe4b08b8857..6135e005bfeb 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.88 2008/01/10 19:58:30 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.89 2008/01/31 06:31:05 graaff Exp $
+*rmagick-2.2.0 (31 Jan 2008)
+
+ 31 Jan 2008; Hans de Graaff <graaff@gentoo.org> +rmagick-2.2.0.ebuild:
+ Version bump: some new functionality made available by newer imagemagick
+ versions, and several bug fixes
+
*rmagick-2.1.0 (10 Jan 2008)
10 Jan 2008; Hans de Graaff <graaff@gentoo.org> +rmagick-2.1.0.ebuild:
diff --git a/dev-ruby/rmagick/files/digest-rmagick-2.2.0 b/dev-ruby/rmagick/files/digest-rmagick-2.2.0
new file mode 100644
index 000000000000..17b24e5d275f
--- /dev/null
+++ b/dev-ruby/rmagick/files/digest-rmagick-2.2.0
@@ -0,0 +1,3 @@
+MD5 2a05dfdeb3d167b10098270592687cac RMagick-2.2.0.tar.bz2 930470
+RMD160 2579eea76e017afd7d9af1937ae2e0281cc28bf4 RMagick-2.2.0.tar.bz2 930470
+SHA256 057022d8cb9e34ba93ebf0382bd5a1002978bd0899d0f596d7dafeab3d1dc60c RMagick-2.2.0.tar.bz2 930470
diff --git a/dev-ruby/rmagick/rmagick-2.2.0.ebuild b/dev-ruby/rmagick/rmagick-2.2.0.ebuild
new file mode 100644
index 000000000000..6c8ff43c8a7e
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-2.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.2.0.ebuild,v 1.1 2008/01/31 06:31:05 graaff Exp $
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+MY_PV=${PV//_/-}
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/31523/RMagick-${MY_PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+DEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.3.5.6"
+
+S="${WORKDIR}/RMagick-${PV}"
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+pkg_setup() {
+ if built_with_use --missing false media-gfx/imagemagick hdri ; then
+ eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
+ die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ fi
+}
+
+# Use a custom src_compile because the setup.rb included with RMagick
+# doesn't like extra parameters during the setup phase.
+src_compile() {
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ RUBY_ECONF="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix=/usr "$@" \
+ ${RUBY_ECONF} ${EXTRA_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb setup || die "setup.rb setup failed"
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step and assumes that arguments can be given
+# also during the install phase.
+src_install() {
+ if ! use doc ; then
+ RUBY_ECONF="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix="${D}/usr" "$@" \
+ ${RUBY_ECONF} ${EXTRA_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix="${D}" || die "setup.rb install failed"
+
+ cd "${S}"
+ dodoc ChangeLog README.html README-Mac-OSX.txt README.txt
+}