summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-12-28 11:16:03 +0000
committerHans de Graaff <graaff@gentoo.org>2009-12-28 11:16:03 +0000
commita060430d132822703934730686ce304490d5c9ba (patch)
tree1c44b16f220d896d51637df2eca26ceba0eb3c45 /dev-ruby/rmagick
parentFix handbook installation, thanks to Maciej Mrozowski. (diff)
downloadgentoo-2-a060430d132822703934730686ce304490d5c9ba.tar.gz
gentoo-2-a060430d132822703934730686ce304490d5c9ba.tar.bz2
gentoo-2-a060430d132822703934730686ce304490d5c9ba.zip
Version bump. Run configure once in the proper phase.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rmagick')
-rw-r--r--dev-ruby/rmagick/ChangeLog7
-rw-r--r--dev-ruby/rmagick/rmagick-2.13.0.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index 5b3927fd40c3..ac980a4dde7a 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.166 2009/12/26 17:35:00 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.167 2009/12/28 11:16:03 graaff Exp $
+
+*rmagick-2.13.0 (28 Dec 2009)
+
+ 28 Dec 2009; Hans de Graaff <graaff@gentoo.org> +rmagick-2.13.0.ebuild:
+ Version bump. Run configure once in the proper phase.
26 Dec 2009; Peter Volkov <pva@gentoo.org> rmagick-2.12.2.ebuild,
rmagick-2.12.2-r1.ebuild:
diff --git a/dev-ruby/rmagick/rmagick-2.13.0.ebuild b/dev-ruby/rmagick/rmagick-2.13.0.ebuild
new file mode 100644
index 000000000000..42caa27e3599
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-2.13.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.13.0.ebuild,v 1.1 2009/12/28 11:16:03 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+MY_PV=${PV//_/-}
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="mirror://rubyforge/rmagick/RMagick-${MY_PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+RDEPEND=">=media-gfx/imagemagick-6.3.5.10[-hdri]"
+DEPEND="${RDEPEND}
+ doc? ( app-text/ghostscript-gpl media-libs/libwmf )"
+
+S="${WORKDIR}/RMagick-${PV}"
+
+each_ruby_configure() {
+ local myconf
+
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ myconf="--disable-htmldoc --allow-example-errors"
+ myconf="${myconf} --doc-dir=${D}/usr/share/doc/${P}/html"
+ fi
+
+ ${RUBY} setup.rb config --prefix="${D}/usr" "$@" \
+ ${myconf} || die "setup.rb config failed"
+}
+
+each_ruby_compile() {
+ ${RUBY} setup.rb setup || die "setup.rb setup failed"
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die "setup.rb install failed"
+}
+
+all_ruby_install() {
+ dodoc ChangeLog README.html README-Mac-OSX.txt || die
+
+ use examples && dodoc examples/*
+}