summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2007-09-17 05:31:23 +0000
committerHans de Graaff <graaff@gentoo.org>2007-09-17 05:31:23 +0000
commitb2bffd4d091b749956f95e98eceb486ede01bca2 (patch)
tree7e056901a637678f8597f2d9a13ed7687fc95f77 /dev-ruby/rmagick
parentAdded default SRC_URI for gems.eclass, to point at rubyforge. (diff)
downloadgentoo-2-b2bffd4d091b749956f95e98eceb486ede01bca2.tar.gz
gentoo-2-b2bffd4d091b749956f95e98eceb486ede01bca2.tar.bz2
gentoo-2-b2bffd4d091b749956f95e98eceb486ede01bca2.zip
Version bump
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-ruby/rmagick')
-rw-r--r--dev-ruby/rmagick/ChangeLog7
-rw-r--r--dev-ruby/rmagick/files/digest-rmagick-1.15.103
-rw-r--r--dev-ruby/rmagick/rmagick-1.15.10.ebuild76
3 files changed, 85 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index 694cf0858c7a..4d0ed7fc3100 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.73 2007/08/04 06:54:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.74 2007/09/17 05:31:23 graaff Exp $
+
+*rmagick-1.15.10 (17 Sep 2007)
+
+ 17 Sep 2007; Hans de Graaff <graaff@gentoo.org> +rmagick-1.15.10.ebuild:
+ Version bump, fixes compatibility issue with ImageMagick-6.3.5-9
*rmagick-1.15.8 (04 Aug 2007)
diff --git a/dev-ruby/rmagick/files/digest-rmagick-1.15.10 b/dev-ruby/rmagick/files/digest-rmagick-1.15.10
new file mode 100644
index 000000000000..f1957942cddc
--- /dev/null
+++ b/dev-ruby/rmagick/files/digest-rmagick-1.15.10
@@ -0,0 +1,3 @@
+MD5 f8c410056395ea4efa09389497c5042f RMagick-1.15.10.tar.bz2 972865
+RMD160 ce2b32d64dbeed0dc3ae5e7ec3e4066d65bf1356 RMagick-1.15.10.tar.bz2 972865
+SHA256 07596567b01108876c6397a57160acf3da2d0e33b38e077158a0c08fd1a1e971 RMagick-1.15.10.tar.bz2 972865
diff --git a/dev-ruby/rmagick/rmagick-1.15.10.ebuild b/dev-ruby/rmagick/rmagick-1.15.10.ebuild
new file mode 100644
index 000000000000..f13f9c39ba73
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-1.15.10.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.15.10.ebuild,v 1.1 2007/09/17 05:31:23 graaff Exp $
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/25348/RMagick-${PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+DEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.0"
+
+S=${WORKDIR}/RMagick-${PV}
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+pkg_setup() {
+ if built_with_use --missing false media-gfx/imagemagick hdri ; then
+ eerror "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ eerror "please rebuild imagemagick without hdri support if you want to use rmagick"
+ die "imagemagick is built with the hdri USE flag, this is not supported by rmagick"
+ fi
+}
+
+# Using a custom src_compile instead of the ruby one because the ruby
+# one gets confused by an additional setup.rb that should not be used
+# here.
+src_compile() {
+ myconf="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ myconf="${myconf} --disable-htmldoc --enable-allow-example-errors"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-ruby=${RUBY} \
+ ${myconf} \
+ "$@" || die "econf failed"
+
+ ruby_emake "$@" || die
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step.
+src_install() {
+ RUBY_ECONF="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ ${RUBY} setup.rb config --prefix=${D}/usr "$@" \
+ ${RUBY_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix=${D} "$@" \
+ ${RUBY_ECONF} || die "setup.rb install failed"
+
+ cd "${S}"
+ dodoc ChangeLog README.html README-Mac-OSX.txt README.txt
+}