summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-04-01 19:30:48 +0000
committerHans de Graaff <graaff@gentoo.org>2014-04-01 19:30:48 +0000
commit22b10f12f2776a880995b27b96f1f4c135f2ca1c (patch)
treef83bde9211d2df44f8b9dabcac995f6ed769ea23 /dev-ruby/rspec-core
parentAdd ruby21. Drop alpha, sparc keywords: bug 465948. (diff)
downloadgentoo-2-22b10f12f2776a880995b27b96f1f4c135f2ca1c.tar.gz
gentoo-2-22b10f12f2776a880995b27b96f1f4c135f2ca1c.tar.bz2
gentoo-2-22b10f12f2776a880995b27b96f1f4c135f2ca1c.zip
Add ruby21. Drop alpha, sparc keywords: bug 465948.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rspec-core')
-rw-r--r--dev-ruby/rspec-core/ChangeLog7
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.14.8-r1.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/dev-ruby/rspec-core/ChangeLog b/dev-ruby/rspec-core/ChangeLog
index 887426a01a22..97a23ac64592 100644
--- a/dev-ruby/rspec-core/ChangeLog
+++ b/dev-ruby/rspec-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.62 2014/03/27 02:00:25 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.63 2014/04/01 19:30:48 graaff Exp $
+
+*rspec-core-2.14.8-r1 (01 Apr 2014)
+
+ 01 Apr 2014; Hans de Graaff <graaff@gentoo.org> +rspec-core-2.14.8-r1.ebuild:
+ Add ruby21. Drop alpha, sparc keywords: bug 465948.
27 Mar 2014; Manuel Rüger <mrueg@gentoo.org> -rspec-core-2.14.3.ebuild,
-rspec-core-2.14.7.ebuild:
diff --git a/dev-ruby/rspec-core/rspec-core-2.14.8-r1.ebuild b/dev-ruby/rspec-core/rspec-core-2.14.8-r1.ebuild
new file mode 100644
index 000000000000..3b8630e5f9ce
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-2.14.8-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.14.8-r1.ebuild,v 1.1 2014/04/01 19:30:48 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+# Also install this custom path since internal paths depend on it.
+RUBY_FAKEGEM_EXTRAINSTALL="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/nokogiri-1.5.2
+ dev-ruby/syntax
+ >=dev-ruby/zentest-4.6.2
+ >=dev-ruby/rspec-expectations-2.14.0:2
+ >=dev-ruby/rspec-mocks-2.12.0:2
+ )"
+
+# Skip yard for ruby20 for now since we don't support ruby20 eselected
+# yet and we can't bootstrap otherwise.
+USE_RUBY=${USE_RUBY/ruby20/} ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Avoid dependency on cucumber since we can't run the features anyway.
+ sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
+
+ # Remove jruby-specific comparison documents since for us the normal
+ # version passes.
+ cp spec/rspec/core/formatters/text_mate_formatted-1.8.7.html spec/rspec/core/formatters/text_mate_formatted-1.8.7-jruby.html|| die
+
+ # Cover all released versions of ruby 2.1.x. This should be reported
+ # upstream since ruby 2.1.x uses semantic versioning and the file
+ # should not have the full version number.
+ cp spec/rspec/core/formatters/text_mate_formatted-2.1.0.html spec/rspec/core/formatters/text_mate_formatted-2.1.1.html|| die
+
+ # Duplicate exe also in bin. We can't change it since internal stuff
+ # also depends on this and fixing that is going to be fragile. This
+ # way we can at least install proper bin scripts.
+ cp -R exe bin || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e '/git ls-files/ s:^:#:' rspec-core.gemspec || die
+
+ # Avoid aruba dependency so that we don't end up in dependency hell.
+ sed -i -e '/aruba/ s:^:#:' -e '104,106 s:^:#:' spec/spec_helper.rb || die
+ rm spec/command_line/order_spec.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ yardoc || die
+ fi
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
+}