summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-09-16 07:00:12 +0000
committerHans de Graaff <graaff@gentoo.org>2012-09-16 07:00:12 +0000
commit1510d364495de330526d1a6884a0c14769a647e1 (patch)
tree8f9426ed4d0bca884d4c70549b05d28436b92aab /dev-ruby/rspec-expectations
parentVersion bump. (diff)
downloadgentoo-2-1510d364495de330526d1a6884a0c14769a647e1.tar.gz
gentoo-2-1510d364495de330526d1a6884a0c14769a647e1.tar.bz2
gentoo-2-1510d364495de330526d1a6884a0c14769a647e1.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog8
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.11.3.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 68b20dc2bccd..4134089b7635 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.31 2012/08/14 18:49:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.32 2012/09/16 07:00:12 graaff Exp $
+
+*rspec-expectations-2.11.3 (16 Sep 2012)
+
+ 16 Sep 2012; Hans de Graaff <graaff@gentoo.org>
+ +rspec-expectations-2.11.3.ebuild:
+ Version bump.
14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Update metadata.xml so that it's the same as most other packages.
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.11.3.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.11.3.ebuild
new file mode 100644
index 000000000000..d907c5cb68ae
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.11.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.11.3.ebuild,v 1.1 2012/09/16 07:00:12 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_S="rspec-${PN}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/tarball/v${PV} -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.3"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.11.0:2
+ dev-ruby/rspec-mocks:2
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}