summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-10 07:37:26 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-10 07:37:26 +0000
commit34c0f877fad2b4d82a62e87aaaeac65de8b23bab (patch)
tree545b7925e7661c6519347ff6c81f4547a6b5b1cd /dev-ruby/rspec
parentx86 stable wrt bug #339778 (diff)
downloadgentoo-2-34c0f877fad2b4d82a62e87aaaeac65de8b23bab.tar.gz
gentoo-2-34c0f877fad2b4d82a62e87aaaeac65de8b23bab.tar.bz2
gentoo-2-34c0f877fad2b4d82a62e87aaaeac65de8b23bab.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec')
-rw-r--r--dev-ruby/rspec/ChangeLog7
-rw-r--r--dev-ruby/rspec/rspec-1.3.1.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-ruby/rspec/ChangeLog b/dev-ruby/rspec/ChangeLog
index 3b0ef89cf824..342d5203f8ae 100644
--- a/dev-ruby/rspec/ChangeLog
+++ b/dev-ruby/rspec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.79 2010/09/18 16:21:44 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.80 2010/10/10 07:37:26 graaff Exp $
+
+*rspec-1.3.1 (10 Oct 2010)
+
+ 10 Oct 2010; Hans de Graaff <graaff@gentoo.org> +rspec-1.3.1.ebuild:
+ Version bump.
18 Sep 2010; Raúl Porcel <armin76@gentoo.org> rspec-2.0.0_beta22.ebuild:
Add ~ia64 wrt #337113
diff --git a/dev-ruby/rspec/rspec-1.3.1.ebuild b/dev-ruby/rspec/rspec-1.3.1.ebuild
new file mode 100644
index 000000000000..f4086a2757e0
--- /dev/null
+++ b/dev-ruby/rspec/rspec-1.3.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.1.ebuild,v 1.1 2010/10/10 07:37:26 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc TODO.txt Ruby1.9.rdoc Upgrade.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# it's actually optional, but tests fail if it's not installed and
+# some other package might fail tests, so require it anyway.
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.2"
+
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.0.0 )"
+
+RDEPEND="!<dev-ruby/rspec-rails-${PV}"
+
+# don't require test dependencies for jruby since we cannot run them
+# for now (fakefs doesn't work).
+#
+# We should add nokogiri here to make sure that we test as much as
+# possible, but since it's yet unported to 1.9 and the nokogiri-due
+# tests fail for sure, we'll be waiting on it.
+USE_RUBY="ruby18 ree18 ruby19" \
+ ruby_add_bdepend "test? (
+ >=dev-ruby/hoe-2.0.0
+ dev-ruby/zentest
+ >=dev-ruby/syntax-1.0
+ >=dev-ruby/fakefs-0.2.1 )"
+
+# the testsuite skips over heckle for Ruby 1.9 so we only request it for 1.8
+USE_RUBY="ruby18 ree18" \
+ ruby_add_bdepend "test? ( >=dev-ruby/heckle-1.4.3 )"
+
+all_ruby_prepare() {
+ # Replace reference to /tmp to our temporary directory to avoid
+ # sandbox-related failure.
+ sed -i \
+ -e "s:/tmp:${T}:" \
+ spec/spec/runner/command_line_spec.rb || die
+}
+
+src_test() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ewarn "Tests for JRuby are disabled because dev-ruby/fakefs does not currently support"
+ ewarn "JRuby properly and it's needed to run the tests."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}