summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-12-05 10:18:29 +0000
committerNaohiro Aota <naota@gentoo.org>2013-12-05 10:18:29 +0000
commit3e9ec7f5f3366fcdf11d6b82468a13f5983798d7 (patch)
tree8354a6b98558090876053a09ce7a7b3b3a9e3094 /dev-ruby/ruby-glib2/ruby-glib2-2.0.2.ebuild
parentAdd ruby20 support (diff)
downloadgentoo-2-3e9ec7f5f3366fcdf11d6b82468a13f5983798d7.tar.gz
gentoo-2-3e9ec7f5f3366fcdf11d6b82468a13f5983798d7.tar.bz2
gentoo-2-3e9ec7f5f3366fcdf11d6b82468a13f5983798d7.zip
version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'dev-ruby/ruby-glib2/ruby-glib2-2.0.2.ebuild')
-rw-r--r--dev-ruby/ruby-glib2/ruby-glib2-2.0.2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ruby/ruby-glib2/ruby-glib2-2.0.2.ebuild b/dev-ruby/ruby-glib2/ruby-glib2-2.0.2.ebuild
new file mode 100644
index 000000000000..15d48c8a583a
--- /dev/null
+++ b/dev-ruby/ruby-glib2/ruby-glib2-2.0.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-glib2/ruby-glib2-2.0.2.ebuild,v 1.1 2013/12/05 10:18:29 naota Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Glib2 bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+RDEPEND="${RDEPEND} >=dev-libs/glib-2"
+DEPEND="${DEPEND}
+ >=dev-libs/glib-2"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}