summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-03-02 10:30:58 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-03-02 10:30:58 +0000
commit7cc667233d3c56f05310c83a83c5b70d82cc89f1 (patch)
treef4ff7d8745cce9a95073c070e944f08bcd5ba230 /dev-ruby/ruby-oci8
parentadd arm64 support, tested on A53 board (diff)
downloadgentoo-2-7cc667233d3c56f05310c83a83c5b70d82cc89f1.tar.gz
gentoo-2-7cc667233d3c56f05310c83a83c5b70d82cc89f1.tar.bz2
gentoo-2-7cc667233d3c56f05310c83a83c5b70d82cc89f1.zip
Create stable candidate.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ruby-oci8')
-rw-r--r--dev-ruby/ruby-oci8/ChangeLog8
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-2.1.7-r1.ebuild40
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-2.1.7.ebuild6
3 files changed, 50 insertions, 4 deletions
diff --git a/dev-ruby/ruby-oci8/ChangeLog b/dev-ruby/ruby-oci8/ChangeLog
index e7814a55caa7..1d95782c20b5 100644
--- a/dev-ruby/ruby-oci8/ChangeLog
+++ b/dev-ruby/ruby-oci8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-oci8
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-oci8/ChangeLog,v 1.31 2015/01/17 10:24:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-oci8/ChangeLog,v 1.32 2015/03/02 10:30:58 mrueg Exp $
+
+*ruby-oci8-2.1.7-r1 (02 Mar 2015)
+
+ 02 Mar 2015; Manuel Rüger <mrueg@gentoo.org> +ruby-oci8-2.1.7-r1.ebuild,
+ ruby-oci8-2.1.7.ebuild:
+ Create stable candidate.
*ruby-oci8-2.1.7 (17 Jan 2015)
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-2.1.7-r1.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-2.1.7-r1.ebuild
new file mode 100644
index 000000000000..0a8b4c6b5316
--- /dev/null
+++ b/dev-ruby/ruby-oci8/ruby-oci8-2.1.7-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-oci8/ruby-oci8-2.1.7-r1.ebuild,v 1.1 2015/03/02 10:30:58 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="NEWS README.md ChangeLog"
+
+DESCRIPTION="A Ruby library for Oracle OCI8"
+HOMEPAGE="https://rubygems.org/gems/ruby-oci8/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-db/oracle-instantclient-basic"
+DEPEND="${RDEPEND}"
+
+EXT_DIR="ext/oci8"
+
+each_ruby_configure() {
+ # configure the native libraries
+ ${RUBY} -C${EXT_DIR} extconf.rb --prefix="${D}/usr" || die "configure failed"
+}
+
+each_ruby_compile() {
+ # compile the native libraries
+ emake -C ${EXT_DIR} V=1 || die "could not compile native library"
+}
+
+each_ruby_install() {
+ # install the native libraries
+ emake -C ${EXT_DIR} install DESTDIR="${D}" || die "could not install native library"
+ # install the gem files
+ each_fakegem_install
+}
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-2.1.7.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-2.1.7.ebuild
index b0d2fd7dfa56..f271fe7a521a 100644
--- a/dev-ruby/ruby-oci8/ruby-oci8-2.1.7.ebuild
+++ b/dev-ruby/ruby-oci8/ruby-oci8-2.1.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-oci8/ruby-oci8-2.1.7.ebuild,v 1.1 2015/01/17 10:24:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-oci8/ruby-oci8-2.1.7.ebuild,v 1.2 2015/03/02 10:30:58 mrueg Exp $
-EAPI="5"
-USE_RUBY="ruby19 ruby20 ruby21"
+EAPI=5
+USE_RUBY="ruby19 ruby20"
inherit multilib ruby-fakegem