summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-29 12:49:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-29 12:49:21 +0000
commit33c8ac77f5643d7cda592a2f2463564530a2b8ec (patch)
treebc6e43e9b159150fe211564626232960fc72cfa6 /dev-ruby/ruby-odbc
parentFix LICENSE: same terms as perl (#301969). Maintenance (diff)
downloadgentoo-2-33c8ac77f5643d7cda592a2f2463564530a2b8ec.tar.gz
gentoo-2-33c8ac77f5643d7cda592a2f2463564530a2b8ec.tar.bz2
gentoo-2-33c8ac77f5643d7cda592a2f2463564530a2b8ec.zip
Version bump, port to ruby-fakegem, drop unicode USE flag and instead always build both ascii and utf8 extensions as they are neither exclusive nor optional.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-odbc')
-rw-r--r--dev-ruby/ruby-odbc/ChangeLog12
-rw-r--r--dev-ruby/ruby-odbc/ruby-odbc-0.9998.ebuild63
2 files changed, 73 insertions, 2 deletions
diff --git a/dev-ruby/ruby-odbc/ChangeLog b/dev-ruby/ruby-odbc/ChangeLog
index d2657832dbc2..d82973bf2a96 100644
--- a/dev-ruby/ruby-odbc/ChangeLog
+++ b/dev-ruby/ruby-odbc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/ruby-odbc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ChangeLog,v 1.13 2009/08/24 19:45:06 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ChangeLog,v 1.14 2010/01/29 12:49:21 flameeyes Exp $
+
+*ruby-odbc-0.9998 (29 Jan 2010)
+
+ 29 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +ruby-odbc-0.9998.ebuild:
+ Version bump, port to ruby-fakegem, drop unicode USE flag and instead
+ always build both ascii and utf8 extensions as they are neither exclusive
+ nor optional.
*ruby-odbc-0.9997 (24 Aug 2009)
diff --git a/dev-ruby/ruby-odbc/ruby-odbc-0.9998.ebuild b/dev-ruby/ruby-odbc/ruby-odbc-0.9998.ebuild
new file mode 100644
index 000000000000..f0113f5bb2ad
--- /dev/null
+++ b/dev-ruby/ruby-odbc/ruby-odbc-0.9998.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ruby-odbc-0.9998.ebuild,v 1.1 2010/01/29 12:49:21 flameeyes Exp $
+
+EAPI=2
+
+# ruby19 → fails to build
+# jruby → uses C extensions
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RubyODBC - For accessing ODBC data sources from the Ruby language"
+HOMEPAGE="http://www.ch-werner.de/rubyodbc/"
+SRC_URI="http://www.ch-werner.de/rubyodbc/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-db/unixODBC-2.0.6"
+RDEPEND="${DEPEND}"
+
+# tests require to have an ODBC service enabled, so we can't run them
+# for now :(
+RESTRICT=test
+
+all_ruby_prepare() {
+ # Make sure that it doesn't try to use the absolute-local path for
+ # the extension as we'd be unable to run it properly otherwise.
+ sed -i -e 's:\./odbc:odbc:' test/{,utf8/}test.rb || die
+
+ # Since lib should not get installed avoid it entirely…
+ mv lib contrib || die
+}
+
+each_ruby_configure() {
+ for dir in ext ext/utf8; do
+ ${RUBY} -C${dir} extconf.rb || die "extconf (${dir}) failed"
+ done
+}
+
+each_ruby_compile() {
+ for dir in ext ext/utf8; do
+ emake -C${dir} || die "emake (${dir}) failed"
+ done
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ ruby_fakegem_newins ext/odbc.so lib/odbc.so
+ ruby_fakegem_newins ext/utf8/odbc_utf8.so lib/odbc_utf8.so
+}
+
+all_ruby_install() {
+ all_fakegem_install
+ dohtml doc/*.html || die
+}