summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-04-29 20:50:13 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-04-29 20:50:13 +0000
commit3f14dde4d7879d948debf7a7fb9bd0ba0b1db575 (patch)
tree3bf53a612aa20c697cfc2f37dbc77e41291836df /dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild
parentinitial commit (diff)
downloadgentoo-2-3f14dde4d7879d948debf7a7fb9bd0ba0b1db575.tar.gz
gentoo-2-3f14dde4d7879d948debf7a7fb9bd0ba0b1db575.tar.bz2
gentoo-2-3f14dde4d7879d948debf7a7fb9bd0ba0b1db575.zip
version bump
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild')
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild
new file mode 100644
index 000000000000..7c0a01e1c01a
--- /dev/null
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild,v 1.1 2006/04/29 20:50:13 caleb Exp $
+
+inherit ruby
+
+DESCRIPTION="OpenGL / GLUT bindings for ruby"
+HOMEPAGE="http://www2.giganet.net/~yoshi/"
+SRC_URI="http://www2.giganet.net/~yoshi/rbogl-${PV}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE=""
+USE_RUBY="ruby16 ruby18 ruby19"
+DEPEND="virtual/ruby
+ virtual/opengl
+ virtual/glut"
+
+S=${WORKDIR}/opengl-${PV}
+
+src_compile() {
+ ruby -i -pe 'sub "PLATFORM","RUBY_PLATFORM"' extconf.rb
+ ruby extconf.rb || die
+ emake -j1 -f Makefile.ogl || die
+ emake -j1 -f Makefile.glut || die
+}
+
+src_install () {
+ make -f Makefile.ogl DESTDIR=${D} install || die "install ogl failed"
+ make -f Makefile.glut DESTDIR=${D} install || die "install glut failed"
+
+ dodoc README.EUC ChangeLog
+
+ insinto /usr/share/${PN}/sample
+ doins sample/*.rb
+}