summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-04-10 16:00:55 +0000
committerMamoru Komachi <usata@gentoo.org>2004-04-10 16:00:55 +0000
commit1b0bc92d3727d561cab7895afa65bc97eb6a2636 (patch)
treedb911c28d4d99824d7f99e77018e927c74ea551f /dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild
parentInitial Import. Closes #47134 (Manifest recommit) (diff)
downloadgentoo-2-1b0bc92d3727d561cab7895afa65bc97eb6a2636.tar.gz
gentoo-2-1b0bc92d3727d561cab7895afa65bc97eb6a2636.tar.bz2
gentoo-2-1b0bc92d3727d561cab7895afa65bc97eb6a2636.zip
virtual/ruby fix
Diffstat (limited to 'dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild')
-rw-r--r--dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild b/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild
index 5e93f31bbff0..0e6ea4a178d1 100644
--- a/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild
+++ b/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild
@@ -1,14 +1,17 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild,v 1.4 2004/02/22 22:26:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild,v 1.5 2004/04/10 15:58:59 usata Exp $
+
+inherit ruby
DESCRIPTION="A Ruby interface to termios"
-HOMEPAGE="http://arika.org/ruby/termios/"
+HOMEPAGE="http://arika.org/ruby/termios" # trailing / isn't needed
SRC_URI="http://arika.org/archive/${P}.tar.gz"
LICENSE="Ruby"
SLOT="0"
KEYWORDS="~alpha ~hppa ~mips ~sparc x86"
-DEPEND=">=dev-lang/ruby-1.6"
+USE_RUBY="ruby16 ruby18 ruby19"
+DEPEND="virtual/ruby"
src_compile() {
ruby extconf.rb || die