summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-05-19 12:49:44 +0000
committerTom William Payne <twp@gentoo.org>2003-05-19 12:49:44 +0000
commitce25f0d20f9eeb659f490e263de794fcd8b9230d (patch)
tree92473b6fc0d9b0d8f0909c9e07232c630c6df1fc /dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild
parentInitial version (diff)
downloadgentoo-2-ce25f0d20f9eeb659f490e263de794fcd8b9230d.tar.gz
gentoo-2-ce25f0d20f9eeb659f490e263de794fcd8b9230d.tar.bz2
gentoo-2-ce25f0d20f9eeb659f490e263de794fcd8b9230d.zip
Initial version
Diffstat (limited to 'dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild')
-rw-r--r--dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild b/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild
new file mode 100644
index 000000000000..654b49cbf2d0
--- /dev/null
+++ b/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild,v 1.1 2003/05/19 12:49:23 twp Exp $
+
+DESCRIPTION="A Ruby interface to termios"
+HOMEPAGE="http://arika.org/ruby/termios/"
+SRC_URI="http://arika.org/archive/${P}.tar.gz"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~sparc ~x86"
+DEPEND=">=dev-lang/ruby-1.6"
+
+src_compile() {
+ ruby extconf.rb || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc ChangeLog README termios.rd
+ docinto examples
+ dodoc examples/*
+}