summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-29 23:18:58 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-29 23:18:58 +0000
commitf4474e9d58cd08c917f0a8a66602570fc29ec656 (patch)
treed2df1321766fe751efebb14dfc628b4b038e460b /dev-ruby/rubypants
parentAdd ruby20 target. (diff)
downloadgentoo-2-f4474e9d58cd08c917f0a8a66602570fc29ec656.tar.gz
gentoo-2-f4474e9d58cd08c917f0a8a66602570fc29ec656.tar.bz2
gentoo-2-f4474e9d58cd08c917f0a8a66602570fc29ec656.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/rubypants')
-rw-r--r--dev-ruby/rubypants/ChangeLog7
-rw-r--r--dev-ruby/rubypants/rubypants-0.2.0-r4.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ruby/rubypants/ChangeLog b/dev-ruby/rubypants/ChangeLog
index d045f3160076..0df28316b022 100644
--- a/dev-ruby/rubypants/ChangeLog
+++ b/dev-ruby/rubypants/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rubypants
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubypants/ChangeLog,v 1.18 2013/09/04 12:37:17 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubypants/ChangeLog,v 1.19 2013/10/29 23:18:58 mrueg Exp $
+
+*rubypants-0.2.0-r4 (30 Oct 2013)
+
+ 30 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +rubypants-0.2.0-r4.ebuild:
+ Add ruby20 target.
04 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -rubypants-0.2.0-r1.ebuild:
Cleanup old.
diff --git a/dev-ruby/rubypants/rubypants-0.2.0-r4.ebuild b/dev-ruby/rubypants/rubypants-0.2.0-r4.ebuild
new file mode 100644
index 000000000000..7baba2f5c4b6
--- /dev/null
+++ b/dev-ruby/rubypants/rubypants-0.2.0-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubypants/rubypants-0.2.0-r4.ebuild,v 1.1 2013/10/29 23:18:58 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby port of the SmartyPants PHP library."
+HOMEPAGE="http://chneukirchen.org/repos/rubypants/README"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # the metadata format is ancient, and has quite a bit of trouble,
+ # remove it and let it use a generated one.
+ rm ../metadata || die
+}
+
+each_ruby_install() {
+ ruby_fakegem_install_gemspec
+
+ ruby_fakegem_newins rubypants.rb lib/rubypants.rb
+}
+
+each_ruby_test() {
+ # The rakefile doesn't really implement it properly, so simply
+ # replace it here.
+ ${RUBY} -I. test_rubypants.rb || die "tests failed"
+}