summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-19 06:11:20 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-19 06:11:20 +0000
commite70213e97f159bbea91352c5ecc74edd9670826c (patch)
treeb9dd634b4d9587226d45c7413955e799d24a1e90 /dev-ruby/shotgun/shotgun-0.9-r1.ebuild
parentdev-embedded/xgpasm is gone (diff)
downloadgentoo-2-e70213e97f159bbea91352c5ecc74edd9670826c.tar.gz
gentoo-2-e70213e97f159bbea91352c5ecc74edd9670826c.tar.bz2
gentoo-2-e70213e97f159bbea91352c5ecc74edd9670826c.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/shotgun/shotgun-0.9-r1.ebuild')
-rw-r--r--dev-ruby/shotgun/shotgun-0.9-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/shotgun/shotgun-0.9-r1.ebuild b/dev-ruby/shotgun/shotgun-0.9-r1.ebuild
new file mode 100644
index 000000000000..c3a9af6022ed
--- /dev/null
+++ b/dev-ruby/shotgun/shotgun-0.9-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shotgun/shotgun-0.9-r1.ebuild,v 1.1 2013/10/19 06:11:20 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Forking implementation of rackup"
+HOMEPAGE="http://rtomayko.github.com/shotgun/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Warning: the code does not use gem versioning to make sure to load
+# only the right rack version so we might need to patch it to work :/
+ruby_add_rdepend 'dev-ruby/rack'
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/shotgun.1
+}