summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-30 18:50:08 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-30 18:50:08 +0000
commit5acce12a024cda46cbdef585b6383a7350286d15 (patch)
tree5c010070a8cef85d81b01e26038a91ab4653a0f3 /dev-ruby/subexec/subexec-0.2.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-5acce12a024cda46cbdef585b6383a7350286d15.tar.gz
gentoo-2-5acce12a024cda46cbdef585b6383a7350286d15.tar.bz2
gentoo-2-5acce12a024cda46cbdef585b6383a7350286d15.zip
Version bump; requires a patch to work properly still.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/subexec/subexec-0.2.2.ebuild')
-rw-r--r--dev-ruby/subexec/subexec-0.2.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/subexec/subexec-0.2.2.ebuild b/dev-ruby/subexec/subexec-0.2.2.ebuild
new file mode 100644
index 000000000000..39e1a9eee3a2
--- /dev/null
+++ b/dev-ruby/subexec/subexec-0.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/subexec/subexec-0.2.2.ebuild,v 1.1 2012/04/30 18:50:08 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 jruby ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem eutils
+
+GITHUB_USER="nulayer"
+
+DESCRIPTION="Subexec spawns an external command with a timeout"
+HOMEPAGE="http://github.com/nulayer/subexec"
+SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="${GITHUB_USER}-${PN}-*"
+
+RUBY_PATCHES=( "${P}-lang.patch" )
+
+ruby_add_bdepend "test? (
+ dev-ruby/shoulda
+ dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ rm Gemfile* || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+ sed -i -e '/begin/,/end/ s:^:#:' spec/spec_helper.rb || die
+}