summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-07-28 20:42:14 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-07-28 20:42:14 +0000
commit0d22d3d7c388c9585266b703dde08fea38ea47d2 (patch)
tree6eab730dfb1fca71725c6006396b148fa597410c /dev-ruby/syslogger
parentVersion bump (diff)
downloadgentoo-2-0d22d3d7c388c9585266b703dde08fea38ea47d2.tar.gz
gentoo-2-0d22d3d7c388c9585266b703dde08fea38ea47d2.tar.bz2
gentoo-2-0d22d3d7c388c9585266b703dde08fea38ea47d2.zip
Version bump
(Portage version: 2.1.13.1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/syslogger')
-rw-r--r--dev-ruby/syslogger/ChangeLog7
-rw-r--r--dev-ruby/syslogger/syslogger-1.5.1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/syslogger/ChangeLog b/dev-ruby/syslogger/ChangeLog
index dadef6d9093d..d7e68171e5b4 100644
--- a/dev-ruby/syslogger/ChangeLog
+++ b/dev-ruby/syslogger/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/syslogger
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/ChangeLog,v 1.8 2013/04/20 06:59:47 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/ChangeLog,v 1.9 2013/07/28 20:42:14 mrueg Exp $
+
+*syslogger-1.5.1 (28 Jul 2013)
+
+ 28 Jul 2013; Manuel Rüger <mrueg@gentoo.org> +syslogger-1.5.1.ebuild:
+ Version bump
*syslogger-1.5.0 (20 Apr 2013)
diff --git a/dev-ruby/syslogger/syslogger-1.5.1.ebuild b/dev-ruby/syslogger/syslogger-1.5.1.ebuild
new file mode 100644
index 000000000000..7f8a6e8fd307
--- /dev/null
+++ b/dev-ruby/syslogger/syslogger-1.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/syslogger-1.5.1.ebuild,v 1.1 2013/07/28 20:42:14 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+# if ever needed
+#GITHUB_USER="crohr"
+#GITHUB_PROJECT="${PN}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Drop-in replacement for the standard Logger, that logs to the syslog"
+HOMEPAGE="https://github.com/crohr/syslogger"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/rdoc-2.4.2 )"
+
+all_ruby_prepare() {
+ sed -i '/[Bb]undler/d' Rakefile || die
+}