summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-19 07:23:35 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-19 07:23:35 +0000
commit1af35ad6b37f877a7838447c12f19c5348b2c06a (patch)
tree66c6a16b4a08e2cd5792d573c0431875c491c7c9 /dev-ruby/treetop
parentCleanup. (diff)
downloadgentoo-2-1af35ad6b37f877a7838447c12f19c5348b2c06a.tar.gz
gentoo-2-1af35ad6b37f877a7838447c12f19c5348b2c06a.tar.bz2
gentoo-2-1af35ad6b37f877a7838447c12f19c5348b2c06a.zip
Add back old treetop version for app-admin/chef.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/treetop')
-rw-r--r--dev-ruby/treetop/ChangeLog5
-rw-r--r--dev-ruby/treetop/treetop-1.4.15-r1.ebuild38
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/treetop/ChangeLog b/dev-ruby/treetop/ChangeLog
index 93476d34dcf4..a3764c9c90f5 100644
--- a/dev-ruby/treetop/ChangeLog
+++ b/dev-ruby/treetop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/treetop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.49 2014/07/18 09:30:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.50 2014/07/19 07:23:35 graaff Exp $
+
+ 19 Jul 2014; Hans de Graaff <graaff@gentoo.org> +treetop-1.4.15-r1.ebuild:
+ Add back old treetop version for app-admin/chef.
18 Jul 2014; Hans de Graaff <graaff@gentoo.org> treetop-1.5.3.ebuild:
Update HOMEPAGE.
diff --git a/dev-ruby/treetop/treetop-1.4.15-r1.ebuild b/dev-ruby/treetop/treetop-1.4.15-r1.ebuild
new file mode 100644
index 000000000000..96d44f611b3c
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.4.15-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/treetop-1.4.15-r1.ebuild,v 1.3 2014/07/19 07:23:35 graaff Exp $
+
+EAPI=5
+
+# jruby fails tests, not investigated yet.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages."
+HOMEPAGE="http://treetop.rubyforge.org/"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-0.10.2 dev-ruby/activesupport )"
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1"
+
+all_ruby_prepare() {
+ # Use a ruby18 compatible regexp, already fixed upstream.
+ sed -i -e 's/\[:\^space:\]/\^[:space:]/' spec/compiler/character_class_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}