summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-28 08:14:14 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-28 08:14:14 +0000
commit71688056e490c18dd6adfa1fb139b28cb6ce4937 (patch)
tree21e27dc7d1784a926882211672e4062be169943b /dev-ruby/tzinfo
parentRemove old version. (diff)
downloadgentoo-2-71688056e490c18dd6adfa1fb139b28cb6ce4937.tar.gz
gentoo-2-71688056e490c18dd6adfa1fb139b28cb6ce4937.tar.bz2
gentoo-2-71688056e490c18dd6adfa1fb139b28cb6ce4937.zip
Revision bump to drop ruby19 from stable version.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/tzinfo')
-rw-r--r--dev-ruby/tzinfo/ChangeLog8
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.31-r1.ebuild40
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.31.ebuild4
3 files changed, 49 insertions, 3 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index 8e555dcdcc44..1bcccdd95509 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.94 2011/12/28 08:10:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.95 2011/12/28 08:14:14 graaff Exp $
+
+*tzinfo-0.3.31-r1 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org> tzinfo-0.3.31.ebuild,
+ +tzinfo-0.3.31-r1.ebuild:
+ Revision bump to drop ruby19 from stable version.
28 Dec 2011; Hans de Graaff <graaff@gentoo.org> -tzinfo-0.3.30.ebuild:
Remove old version.
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.31-r1.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.31-r1.ebuild
new file mode 100644
index 000000000000..a7386eaafa49
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.31-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.31-r1.ebuild,v 1.1 2011/12/28 08:14:14 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+# No longer compatible with rake 0.9 starting with 0.3.31.
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+each_ruby_test() {
+ TZ='America/Los_Angeles' ${RUBY} -I. -S testrb test/tc_*.rb || die
+}
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild
index 7ad009f09248..673a3f4712c5 100644
--- a/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild
+++ b/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild,v 1.5 2011/12/18 15:52:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.31.ebuild,v 1.6 2011/12/28 08:14:14 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18 ree18 jruby"
# No longer compatible with rake 0.9 starting with 0.3.31.
RUBY_FAKEGEM_TASK_DOC=""