summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-28 06:31:06 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-28 06:31:06 +0000
commit854a759b31441d19dd2265a330864b3cef52ddc9 (patch)
tree983ae827619a443b385d3071789974eabef13fb7 /dev-ruby/tzinfo
parentUse system libwebp. (diff)
downloadgentoo-2-854a759b31441d19dd2265a330864b3cef52ddc9.tar.gz
gentoo-2-854a759b31441d19dd2265a330864b3cef52ddc9.tar.bz2
gentoo-2-854a759b31441d19dd2265a330864b3cef52ddc9.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/tzinfo')
-rw-r--r--dev-ruby/tzinfo/ChangeLog7
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.27.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index f3af83c93040..42e26c277b1d 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.77 2011/04/02 23:18:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.78 2011/04/28 06:31:06 graaff Exp $
+
+*tzinfo-0.3.27 (28 Apr 2011)
+
+ 28 Apr 2011; Hans de Graaff <graaff@gentoo.org> +tzinfo-0.3.27.ebuild:
+ Version bump.
*tzinfo-0.3.26 (02 Apr 2011)
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.27.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.27.ebuild
new file mode 100644
index 000000000000..522385dd1d7a
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.27.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.27.ebuild,v 1.1 2011/04/28 06:31:06 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}