summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-21 20:11:53 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-21 20:11:53 +0000
commit2695c238c286dd32de7b88263583587835e92d97 (patch)
tree04651804daec246cdc10c853a76f5c7fe340ddd2 /dev-ruby
parentVersion bump for Rails 2.3.11. (diff)
downloadgentoo-2-2695c238c286dd32de7b88263583587835e92d97.tar.gz
gentoo-2-2695c238c286dd32de7b88263583587835e92d97.tar.bz2
gentoo-2-2695c238c286dd32de7b88263583587835e92d97.zip
Version bump for Rails 2.3.11.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.11.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 25cb11cbbca4..aec6304099cc 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.150 2011/02/21 19:55:35 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.151 2011/02/21 20:11:53 graaff Exp $
+
+*activerecord-2.3.11 (21 Feb 2011)
+
+ 21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.3.11.ebuild:
+ Version bump for Rails 2.3.11.
21 Feb 2011; Hans de Graaff <graaff@gentoo.org>
activerecord-2.3.10.ebuild, +files/activerecord-2.3.10-rails3.patch:
diff --git a/dev-ruby/activerecord/activerecord-2.3.11.ebuild b/dev-ruby/activerecord/activerecord-2.3.11.ebuild
new file mode 100644
index 000000000000..02bbae39c7d6
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.11.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.11.ebuild,v 1.1 2011/02/21 20:11:53 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3" #sqlite
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+
+#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
+USE_RUBY=ruby18 \
+ ruby_add_rdepend "
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${PN}-2.3.10-rails3.patch"
+
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}