summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Wilmott <p8952@gentoo.org>2014-05-26 13:22:03 +0000
committerPeter Wilmott <p8952@gentoo.org>2014-05-26 13:22:03 +0000
commit29cabc4cc5add195d387ec2766f2e9698f374582 (patch)
tree4c022a08547d8c43346cdfaaba1ec8dbebd4d9f7 /dev-ruby
parentApply upstream patch for bug 466144 to fix exo_str_looks_like_an_uri() functi... (diff)
downloadgentoo-2-29cabc4cc5add195d387ec2766f2e9698f374582.tar.gz
gentoo-2-29cabc4cc5add195d387ec2766f2e9698f374582.tar.bz2
gentoo-2-29cabc4cc5add195d387ec2766f2e9698f374582.zip
Fix tests and add ruby21 target
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/RubyInline/ChangeLog7
-rw-r--r--dev-ruby/RubyInline/RubyInline-3.12.3-r1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/RubyInline/ChangeLog b/dev-ruby/RubyInline/ChangeLog
index 7a436178419f..0aa6a947402a 100644
--- a/dev-ruby/RubyInline/ChangeLog
+++ b/dev-ruby/RubyInline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/RubyInline
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/ChangeLog,v 1.19 2014/05/04 13:36:27 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/ChangeLog,v 1.20 2014/05/26 13:22:03 p8952 Exp $
+
+*RubyInline-3.12.3-r1 (26 May 2014)
+
+ 26 May 2014; Peter Wilmott <p8952@gentoo.org> +RubyInline-3.12.3-r1.ebuild:
+ Fix tests and add ruby21 target
*RubyInline-3.12.3 (04 May 2014)
diff --git a/dev-ruby/RubyInline/RubyInline-3.12.3-r1.ebuild b/dev-ruby/RubyInline/RubyInline-3.12.3-r1.ebuild
new file mode 100644
index 000000000000..a47bf6abdd32
--- /dev/null
+++ b/dev-ruby/RubyInline/RubyInline-3.12.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/RubyInline-3.12.3-r1.ebuild,v 1.1 2014/05/26 13:22:03 p8952 Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/zentest"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-3
+ dev-ruby/hoe-seattlerb
+ dev-ruby/minitest:5
+ )"
+
+RUBY_PATCHES=(
+ ruby-inline-3.12.2-gentoo.patch
+ ruby-inline-3.11.1-ldflags.patch
+)
+
+all_ruby_prepare() {
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb
+}