summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-10 06:43:45 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-10 06:43:45 +0000
commit2eb0368f28b199fd09c01bf682c0b40b30a8a668 (patch)
tree7213c74c945d0ec34f599bf64187daabbdde895f /dev-ruby
parentVersion bump for security bug 430718. (diff)
downloadgentoo-2-2eb0368f28b199fd09c01bf682c0b40b30a8a668.tar.gz
gentoo-2-2eb0368f28b199fd09c01bf682c0b40b30a8a668.tar.bz2
gentoo-2-2eb0368f28b199fd09c01bf682c0b40b30a8a668.zip
Version bump for security bug 430718.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.2.8.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 84dbd6bd1ca9..3f5ba24337f1 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.214 2012/07/29 07:41:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.215 2012/08/10 06:43:45 graaff Exp $
+
+*actionpack-3.2.8 (10 Aug 2012)
+
+ 10 Aug 2012; Hans de Graaff <graaff@gentoo.org> +actionpack-3.2.8.ebuild:
+ Version bump for security bug 430718.
29 Jul 2012; Hans de Graaff <graaff@gentoo.org> -actionpack-3.0.15.ebuild,
-actionpack-3.1.6.ebuild, -actionpack-3.2.6.ebuild:
diff --git a/dev-ruby/actionpack/actionpack-3.2.8.ebuild b/dev-ruby/actionpack/actionpack-3.2.8.ebuild
new file mode 100644
index 000000000000..4b58fb1df6f9
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.2.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.2.8.ebuild,v 1.1 2012/08/10 06:43:45 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-cache-1.2
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/i18n-0.6:0.6
+ >=dev-ruby/rack-1.4.0:1.4
+ >=dev-ruby/rack-test-0.6.1:0.6
+ >=dev-ruby/journey-1.0.4:1.0
+ >=dev-ruby/sprockets-2.1.3:2.1"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.12.1
+ dev-ruby/bundler
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ >=dev-ruby/tzinfo-0.3.29
+ >=dev-ruby/uglifier-1.0.3
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\)/d" ../Gemfile || die
+
+ sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+
+ # Avoid fragile tests depending on hash ordering
+ sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
+ sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
+ sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+}