summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-02-11 20:11:40 +0000
committerHans de Graaff <graaff@gentoo.org>2013-02-11 20:11:40 +0000
commit46b77c09ce06ed2759632f770f80c738984ae95e (patch)
tree629e974f5a30717d62aead2a742bd644d6b75d86 /dev-ruby
parentVersion bump for security bug 456840. (diff)
downloadgentoo-2-46b77c09ce06ed2759632f770f80c738984ae95e.tar.gz
gentoo-2-46b77c09ce06ed2759632f770f80c738984ae95e.tar.bz2
gentoo-2-46b77c09ce06ed2759632f770f80c738984ae95e.zip
Version bump for security bug 456840.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-3.2.12.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 049d0fca3e87..16ecfd97e9fe 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.143 2013/02/11 19:15:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.144 2013/02/11 20:11:40 graaff Exp $
+
+*activeresource-3.2.12 (11 Feb 2013)
+
+ 11 Feb 2013; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-3.2.12.ebuild:
+ Version bump for security bug 456840.
11 Feb 2013; Hans de Graaff <graaff@gentoo.org>
-activeresource-2.3.15.ebuild, -activeresource-3.0.19.ebuild,
diff --git a/dev-ruby/activeresource/activeresource-3.2.12.ebuild b/dev-ruby/activeresource/activeresource-3.2.12.ebuild
new file mode 100644
index 000000000000..cb96508f6177
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.2.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.2.12.ebuild,v 1.1 2013/02/11 20:11:40 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Avoid test broken by security fixes.
+ sed -i -e '/test_load_yaml_array/,/^ end/ s:^:#:' test/cases/base_test.rb || die
+}