summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2011-07-25 08:56:25 +0000
committerBenedikt Boehm <hollow@gentoo.org>2011-07-25 08:56:25 +0000
commit4c51e782bbbde4f336b08d06a74d1c7dfd0364be (patch)
treead2d07ec425945bc38599379fa315fc699968f3f /dev-ruby
parentinitial ebuild. required by app-admin/chef-expander. (diff)
downloadgentoo-2-4c51e782bbbde4f336b08d06a74d1c7dfd0364be.tar.gz
gentoo-2-4c51e782bbbde4f336b08d06a74d1c7dfd0364be.tar.bz2
gentoo-2-4c51e782bbbde4f336b08d06a74d1c7dfd0364be.zip
initial ebuild. required by app-admin/chef-expander.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fast_xs/ChangeLog10
-rw-r--r--dev-ruby/fast_xs/fast_xs-0.7.3.ebuild31
-rw-r--r--dev-ruby/fast_xs/metadata.xml5
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/fast_xs/ChangeLog b/dev-ruby/fast_xs/ChangeLog
new file mode 100644
index 000000000000..e1af94e77b63
--- /dev/null
+++ b/dev-ruby/fast_xs/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/fast_xs
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_xs/ChangeLog,v 1.1 2011/07/25 08:56:25 hollow Exp $
+
+*fast_xs-0.7.3 (25 Jul 2011)
+
+ 25 Jul 2011; Benedikt Böhm <hollow@gentoo.org> +fast_xs-0.7.3.ebuild,
+ +metadata.xml:
+ initial ebuild. required by app-admin/chef-expander.
+
diff --git a/dev-ruby/fast_xs/fast_xs-0.7.3.ebuild b/dev-ruby/fast_xs/fast_xs-0.7.3.ebuild
new file mode 100644
index 000000000000..2cf4bb244df3
--- /dev/null
+++ b/dev-ruby/fast_xs/fast_xs-0.7.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_xs/fast_xs-0.7.3.ebuild,v 1.1 2011/07/25 08:56:25 hollow Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="fast_xs text escaping library ruby bindings."
+HOMEPAGE="http://fast-xs.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/fast_xs extconf.rb || die "extconf.rb failed"
+ ${RUBY} -Cext/fast_xs_extra extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext/fast_xs CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "make extension failed"
+ cp ext/fast_xs/fast_xs$(get_modname) lib/ || die
+ emake -Cext/fast_xs_extra CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "make extension failed"
+ cp ext/fast_xs_extra/fast_xs_extra$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/fast_xs/metadata.xml b/dev-ruby/fast_xs/metadata.xml
new file mode 100644
index 000000000000..0040b1162894
--- /dev/null
+++ b/dev-ruby/fast_xs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+</pkgmetadata>