summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-06-07 05:41:41 +0000
committerHans de Graaff <graaff@gentoo.org>2014-06-07 05:41:41 +0000
commit4e389c1d80d1bd35a08894e6b36309297c7e05ee (patch)
tree6e3b0636a465ee1a45790a29b8795197c676c42c /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-4e389c1d80d1bd35a08894e6b36309297c7e05ee.tar.gz
gentoo-2-4e389c1d80d1bd35a08894e6b36309297c7e05ee.tar.bz2
gentoo-2-4e389c1d80d1bd35a08894e6b36309297c7e05ee.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rb-inotify/ChangeLog7
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-ruby/rb-inotify/ChangeLog b/dev-ruby/rb-inotify/ChangeLog
index 9ada43890e26..2aa967aa7574 100644
--- a/dev-ruby/rb-inotify/ChangeLog
+++ b/dev-ruby/rb-inotify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rb-inotify
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/ChangeLog,v 1.29 2014/05/03 09:28:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/ChangeLog,v 1.30 2014/06/07 05:41:41 graaff Exp $
+
+*rb-inotify-0.9.5 (07 Jun 2014)
+
+ 07 Jun 2014; Hans de Graaff <graaff@gentoo.org> +rb-inotify-0.9.5.ebuild:
+ Version bump.
*rb-inotify-0.9.4 (03 May 2014)
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild
new file mode 100644
index 000000000000..55954a86950f
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild,v 1.1 2014/06/07 05:41:41 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+RUBY_FAKEGEM_GEMSPEC="rb-inotify.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI."
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # jruby has a native implementation and should not list ffi
+ # in the gemspec.
+ sed -i -e '/ffi/d' rb-inotify.gemspec || die
+ ;;
+ *)
+ ;;
+ esac
+}