summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-01-13 02:49:30 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-01-13 02:49:30 +0000
commit57a5ee23af80fc68fe52121240c22df06fb46f14 (patch)
treeb5b942e97cdfcd0ef5be98d0fc9f5a08e5eb8d91 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-57a5ee23af80fc68fe52121240c22df06fb46f14.tar.gz
gentoo-2-57a5ee23af80fc68fe52121240c22df06fb46f14.tar.bz2
gentoo-2-57a5ee23af80fc68fe52121240c22df06fb46f14.zip
Version bump.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/vlad/ChangeLog9
-rw-r--r--dev-ruby/vlad/vlad-2.6.3.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-ruby/vlad/ChangeLog b/dev-ruby/vlad/ChangeLog
index ac53efefd4eb..d986b1c330d9 100644
--- a/dev-ruby/vlad/ChangeLog
+++ b/dev-ruby/vlad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/vlad
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/ChangeLog,v 1.25 2013/11/02 20:40:22 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/ChangeLog,v 1.26 2014/01/13 02:49:30 mrueg Exp $
+
+*vlad-2.6.3 (13 Jan 2014)
+
+ 13 Jan 2014; Manuel Rüger <mrueg@gentoo.org> +vlad-2.6.3.ebuild:
+ Version bump.
02 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -vlad-2.2.5.ebuild,
-vlad-2.3.1.ebuild, -vlad-2.4.1.ebuild, -vlad-2.6.1.ebuild,
diff --git a/dev-ruby/vlad/vlad-2.6.3.ebuild b/dev-ruby/vlad/vlad-2.6.3.ebuild
new file mode 100644
index 000000000000..a28881486138
--- /dev/null
+++ b/dev-ruby/vlad/vlad-2.6.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/vlad-2.6.3.ebuild,v 1.1 2014/01/13 02:49:30 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pragmatic application deployment automation, without mercy."
+HOMEPAGE="http://rubyhitsquad.com/Vlad_the_Deployer.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-2.9.2 test? ( dev-ruby/minitest )"
+ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.1"
+
+all_ruby_prepare() {
+ # Keep Isolate from managing the dependencies.
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}