summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-05-12 05:31:37 +0000
committerHans de Graaff <graaff@gentoo.org>2015-05-12 05:31:37 +0000
commit6f4626b797f93378f34d3c5cda1ee9f63cd145b3 (patch)
tree4bde7b5480393be339182095eb1827d898c97910 /dev-ruby
parentAdopting the package. Revision bump to regenerate configure (bug #549184) an... (diff)
downloadgentoo-2-6f4626b797f93378f34d3c5cda1ee9f63cd145b3.tar.gz
gentoo-2-6f4626b797f93378f34d3c5cda1ee9f63cd145b3.tar.bz2
gentoo-2-6f4626b797f93378f34d3c5cda1ee9f63cd145b3.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/acts_as_list/ChangeLog7
-rw-r--r--dev-ruby/acts_as_list/acts_as_list-0.7.2.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/acts_as_list/ChangeLog b/dev-ruby/acts_as_list/ChangeLog
index 94b6503c6716..bcecb72f2aa0 100644
--- a/dev-ruby/acts_as_list/ChangeLog
+++ b/dev-ruby/acts_as_list/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/acts_as_list
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/acts_as_list/ChangeLog,v 1.12 2015/05/03 19:12:08 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/acts_as_list/ChangeLog,v 1.13 2015/05/12 05:31:37 graaff Exp $
+
+*acts_as_list-0.7.2 (12 May 2015)
+
+ 12 May 2015; Hans de Graaff <graaff@gentoo.org> +acts_as_list-0.7.2.ebuild:
+ Version bump.
*acts_as_list-0.7.0 (03 May 2015)
diff --git a/dev-ruby/acts_as_list/acts_as_list-0.7.2.ebuild b/dev-ruby/acts_as_list/acts_as_list-0.7.2.ebuild
new file mode 100644
index 000000000000..e9d607044892
--- /dev/null
+++ b/dev-ruby/acts_as_list/acts_as_list-0.7.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/acts_as_list/acts_as_list-0.7.2.ebuild,v 1.1 2015/05/12 05:31:37 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+DESCRIPTION="Capabilities for sorting and reordering a number of objects in a list"
+HOMEPAGE="https://github.com/swanandp/acts_as_list"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activerecord-3:*"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ dev-ruby/activerecord:3.2[sqlite3]
+ )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '1,9 s:^:#:' test/helper.rb || die
+ sed -i -e '/git ls/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Tests currently only pass on rails 3.
+ sed -e '1igem "activerecord", "~>3.2.0"' -i test/helper.rb || die
+}