summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-17 18:10:28 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-17 18:10:28 +0000
commit70a5a2fa5ff45c96fa9109e327aca360a47bf264 (patch)
tree8366f6b9c0321edceb12b60695301d22af733e9f /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-70a5a2fa5ff45c96fa9109e327aca360a47bf264.tar.gz
gentoo-2-70a5a2fa5ff45c96fa9109e327aca360a47bf264.tar.bz2
gentoo-2-70a5a2fa5ff45c96fa9109e327aca360a47bf264.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/i18n/ChangeLog7
-rw-r--r--dev-ruby/i18n/i18n-0.6.0.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index 8f05e914f8ce..6cf30e06c4e3 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.32 2011/02/26 18:34:53 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.33 2011/06/17 18:10:28 graaff Exp $
+
+*i18n-0.6.0 (17 Jun 2011)
+
+ 17 Jun 2011; Hans de Graaff <graaff@gentoo.org> +i18n-0.6.0.ebuild:
+ Version bump.
26 Feb 2011; Raúl Porcel <armin76@gentoo.org> i18n-0.5.0-r1.ebuild:
Add ~ia64/~sparc/~x86 wrt #355697
diff --git a/dev-ruby/i18n/i18n-0.6.0.ebuild b/dev-ruby/i18n/i18n-0.6.0.ebuild
new file mode 100644
index 000000000000..4f7748c7cf31
--- /dev/null
+++ b/dev-ruby/i18n/i18n-0.6.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.6.0.ebuild,v 1.1 2011/06/17 18:10:28 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 jruby ree18"
+
+# doc regeneration seem to need Jeweler, which is not currently
+# available
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.textile CHANGELOG.textile"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Add Internationalization support to your Ruby application."
+HOMEPAGE="http://rails-i18n.org/"
+
+SRC_URI="http://github.com/svenfuchs/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/svenfuchs-${PN}-*"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~hppa ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# The testsuite uses the activerecord gem to run some tests; they
+# require sqlite3-ruby, and that is not available on JRuby.
+#USE_RUBY="${USE_RUBY/jruby/}" \
+# ruby_add_bdepend "
+# test? (
+# dev-ruby/activerecord
+# dev-ruby/sqlite3-ruby
+# dev-ruby/ruby2ruby
+# )"
+
+# mocha is optionally used by the testsuite, try to increase coverage
+# of testing by depending on it; when mocha is used, though,
+# test-unit:2 cannot be merged at the same time (mocha problem?)
+#
+# One further test dependency would be ruby-cldr
+# (http://rubygems.org/gems/ruby-cldr) but we don't have it in tree
+# yet.
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ dev-ruby/test_declarative
+ )"
+
+src_compile() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_compile
+}
+
+src_test() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}
+
+each_ruby_test() {
+ # Make sure the optional activerecord tests are not run for jruby
+ # because we don't ship a compatible sqlite3
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ each_fakegem_test
+ esac
+}