summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-06-09 14:39:00 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-06-09 14:39:00 +0000
commit7bcbdc3116a53e18520defa9c5e91c2f85476f0a (patch)
treef0c056b6267b1cfbe926f5c098eaae19dfa5a5c1 /dev-ruby
parentVersion bump for Gnome 3.16. (diff)
downloadgentoo-2-7bcbdc3116a53e18520defa9c5e91c2f85476f0a.tar.gz
gentoo-2-7bcbdc3116a53e18520defa9c5e91c2f85476f0a.tar.bz2
gentoo-2-7bcbdc3116a53e18520defa9c5e91c2f85476f0a.zip
Rename sqlite3 USEflag to sqlite. Fixes bug #548654.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-3.2.21.ebuild20
-rw-r--r--dev-ruby/activerecord/activerecord-4.0.13.ebuild8
-rw-r--r--dev-ruby/activerecord/activerecord-4.1.10.ebuild8
-rw-r--r--dev-ruby/activerecord/activerecord-4.2.1.ebuild8
5 files changed, 25 insertions, 26 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 4e4185d3b8a1..fec545c06fbc 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.292 2015/06/07 16:41:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.293 2015/06/09 14:39:00 mrueg Exp $
+
+ 09 Jun 2015; Manuel Rüger <mrueg@gentoo.org> activerecord-3.2.21.ebuild,
+ activerecord-4.0.13.ebuild, activerecord-4.1.10.ebuild,
+ activerecord-4.2.1.ebuild:
+ Rename sqlite3 USEflag to sqlite. Fixes bug #548654.
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-ruby/activerecord/activerecord-3.2.21.ebuild b/dev-ruby/activerecord/activerecord-3.2.21.ebuild
index 9c71fdae22c6..562378010de9 100644
--- a/dev-ruby/activerecord/activerecord-3.2.21.ebuild
+++ b/dev-ruby/activerecord/activerecord-3.2.21.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.2.21.ebuild,v 1.1 2014/11/17 20:20:00 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.2.21.ebuild,v 1.2 2015/06/09 14:39:00 mrueg Exp $
EAPI=5
USE_RUBY="ruby19 ruby20"
@@ -22,7 +22,7 @@ SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
+IUSE="mysql postgres sqlite"
RUBY_S="rails-${PV}/${PN}"
@@ -30,7 +30,7 @@ ruby_add_rdepend "~dev-ruby/activesupport-${PV}
~dev-ruby/activemodel-${PV}
>=dev-ruby/arel-3.0.2:3.0
>=dev-ruby/tzinfo-0.3.29:0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.5 )
+ sqlite? ( >=dev-ruby/sqlite3-1.3.5 )
mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
postgres? ( >=dev-ruby/pg-0.11.0 )"
@@ -63,13 +63,7 @@ all_ruby_prepare() {
}
each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -I. -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
+ if use sqlite; then
+ ${RUBY} -I. -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
}
diff --git a/dev-ruby/activerecord/activerecord-4.0.13.ebuild b/dev-ruby/activerecord/activerecord-4.0.13.ebuild
index 361fecd53510..557b2027fbf5 100644
--- a/dev-ruby/activerecord/activerecord-4.0.13.ebuild
+++ b/dev-ruby/activerecord/activerecord-4.0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.0.13.ebuild,v 1.1 2015/01/07 07:05:49 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.0.13.ebuild,v 1.2 2015/06/09 14:39:00 mrueg Exp $
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"
@@ -22,7 +22,7 @@ SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="mysql postgres sqlite3"
+IUSE="mysql postgres sqlite"
RUBY_S="rails-${PV}/${PN}"
@@ -30,7 +30,7 @@ ruby_add_rdepend "~dev-ruby/activesupport-${PV}
~dev-ruby/activemodel-${PV}
>=dev-ruby/activerecord-deprecated_finders-1.0.2:1.0
>=dev-ruby/arel-4.0.2:4.0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.5 )
+ sqlite? ( >=dev-ruby/sqlite3-1.3.5 )
mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
postgres? ( >=dev-ruby/pg-0.11.0 )
!<dev-ruby/protected_attributes-1.0.8"
@@ -72,7 +72,7 @@ each_ruby_test() {
*jruby)
;;
*)
- if use sqlite3; then
+ if use sqlite; then
${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
fi
;;
diff --git a/dev-ruby/activerecord/activerecord-4.1.10.ebuild b/dev-ruby/activerecord/activerecord-4.1.10.ebuild
index cd1e04d4fbe9..23ed822e4ca6 100644
--- a/dev-ruby/activerecord/activerecord-4.1.10.ebuild
+++ b/dev-ruby/activerecord/activerecord-4.1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.1.10.ebuild,v 1.1 2015/03/19 19:25:27 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.1.10.ebuild,v 1.2 2015/06/09 14:39:00 mrueg Exp $
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"
@@ -22,14 +22,14 @@ SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz
LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
-IUSE="mysql postgres sqlite3"
+IUSE="mysql postgres sqlite"
RUBY_S="rails-${PV}/${PN}"
ruby_add_rdepend "~dev-ruby/activesupport-${PV}
~dev-ruby/activemodel-${PV}
>=dev-ruby/arel-5.0.0:5.0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.6 )
+ sqlite? ( >=dev-ruby/sqlite3-1.3.6 )
mysql? ( >=dev-ruby/mysql2-0.3.13:0.3 )
postgres? ( >=dev-ruby/pg-0.11.0 )"
@@ -66,7 +66,7 @@ all_ruby_prepare() {
}
each_ruby_test() {
- if use sqlite3; then
+ if use sqlite; then
${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
fi
}
diff --git a/dev-ruby/activerecord/activerecord-4.2.1.ebuild b/dev-ruby/activerecord/activerecord-4.2.1.ebuild
index 1daf6ba6112a..d8071cb1239a 100644
--- a/dev-ruby/activerecord/activerecord-4.2.1.ebuild
+++ b/dev-ruby/activerecord/activerecord-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.2.1.ebuild,v 1.1 2015/03/19 19:25:27 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.2.1.ebuild,v 1.2 2015/06/09 14:39:00 mrueg Exp $
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"
@@ -22,14 +22,14 @@ SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz
LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
-IUSE="mysql postgres sqlite3"
+IUSE="mysql postgres sqlite"
RUBY_S="rails-${PV}/${PN}"
ruby_add_rdepend "~dev-ruby/activesupport-${PV}
~dev-ruby/activemodel-${PV}
>=dev-ruby/arel-6.0:6.0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.6 )
+ sqlite? ( >=dev-ruby/sqlite3-1.3.6 )
mysql? ( >=dev-ruby/mysql2-0.3.13:0.3 )
postgres? ( >=dev-ruby/pg-0.15.0 )"
@@ -68,7 +68,7 @@ all_ruby_prepare() {
}
each_ruby_test() {
- if use sqlite3; then
+ if use sqlite; then
${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
fi
}