summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-09-09 13:12:42 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-09-09 13:12:42 +0000
commit837ad48bb865339b40f040bbc492a00ec35982aa (patch)
treef9e8f8721d5c15646c5dcd503833ebb482cbef5b /dev-ruby
parentRemove jruby support as only older storable works with that. (diff)
downloadgentoo-2-837ad48bb865339b40f040bbc492a00ec35982aa.tar.gz
gentoo-2-837ad48bb865339b40f040bbc492a00ec35982aa.tar.bz2
gentoo-2-837ad48bb865339b40f040bbc492a00ec35982aa.zip
Version bump, remove older versions.
(Portage version: 2.2_rc78/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/storable/ChangeLog9
-rw-r--r--dev-ruby/storable/storable-0.7.4.ebuild47
-rw-r--r--dev-ruby/storable/storable-0.8.1.ebuild52
-rw-r--r--dev-ruby/storable/storable-0.8.2.ebuild (renamed from dev-ruby/storable/storable-0.8.0.ebuild)4
4 files changed, 10 insertions, 102 deletions
diff --git a/dev-ruby/storable/ChangeLog b/dev-ruby/storable/ChangeLog
index 0b45eeb20683..3fdfc0837451 100644
--- a/dev-ruby/storable/ChangeLog
+++ b/dev-ruby/storable/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/storable
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.14 2010/08/01 14:09:24 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.15 2010/09/09 13:12:42 flameeyes Exp $
+
+*storable-0.8.2 (09 Sep 2010)
+
+ 09 Sep 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -storable-0.7.4.ebuild, -storable-0.8.0.ebuild, -storable-0.8.1.ebuild,
+ +storable-0.8.2.ebuild:
+ Version bump, remove older versions.
*storable-0.8.1 (01 Aug 2010)
diff --git a/dev-ruby/storable/storable-0.7.4.ebuild b/dev-ruby/storable/storable-0.7.4.ebuild
deleted file mode 100644
index dcd18dd83a14..000000000000
--- a/dev-ruby/storable/storable-0.7.4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.7.4.ebuild,v 1.3 2010/07/28 23:22:35 flameeyes Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Marshal Ruby classes into and out of multiple formats"
-HOMEPAGE="http://solutious.com/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-SRC_URI="http://github.com/delano/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/delano-${PN}-*"
-
-# technically, it could work without either; on the other hand, it
-# would break a bit of stuff.
-ruby_add_rdepend "|| ( dev-ruby/json dev-ruby/yajl-ruby )"
-
-ruby_add_bdepend "test? ( dev-ruby/tryouts:0 )"
-
-all_ruby_prepare() {
- mv bin examples || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -S sergeant || die "tests failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/* || die
-}
diff --git a/dev-ruby/storable/storable-0.8.1.ebuild b/dev-ruby/storable/storable-0.8.1.ebuild
deleted file mode 100644
index b0be67611a43..000000000000
--- a/dev-ruby/storable/storable-0.8.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.8.1.ebuild,v 1.1 2010/08/01 14:09:25 flameeyes Exp $
-
-EAPI=2
-
-# jruby → yajl-ruby won't work, as it's compiled extension
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Marshal Ruby classes into and out of multiple formats"
-HOMEPAGE="http://solutious.com/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-SRC_URI="http://github.com/delano/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/delano-${PN}-*"
-
-# technically, it could work without either; on the other hand, it
-# would break a bit of stuff.
-#ruby_add_rdepend "|| ( dev-ruby/json dev-ruby/yajl-ruby )"
-
-# Somehow it infinite-recurse if JSON is used, see issue #1, so use
-# yajl directly.
-ruby_add_rdepend dev-ruby/yajl-ruby
-
-ruby_add_bdepend "test? ( dev-ruby/tryouts:2 )"
-
-all_ruby_prepare() {
- mv bin examples || die
-}
-
-each_ruby_test() {
- ${RUBY} -S try || die "tests failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/* || die
-}
diff --git a/dev-ruby/storable/storable-0.8.0.ebuild b/dev-ruby/storable/storable-0.8.2.ebuild
index 86878eceffd4..d76d4a10351e 100644
--- a/dev-ruby/storable/storable-0.8.0.ebuild
+++ b/dev-ruby/storable/storable-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.8.0.ebuild,v 1.1 2010/07/28 23:22:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.8.2.ebuild,v 1.1 2010/09/09 13:12:42 flameeyes Exp $
EAPI=2
@@ -23,7 +23,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-SRC_URI="http://github.com/delano/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+SRC_URI="http://github.com/delano/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
S="${WORKDIR}/delano-${PN}-*"
# technically, it could work without either; on the other hand, it