summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-04 09:32:36 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-04 09:32:36 +0000
commit881fb20318f4bc9673f630f88d5a615955b5dbb1 (patch)
treea63179a2c10bf4a644056526a47a54462d595d47 /dev-ruby
parentVersion bump for Rails 3.0.9. (diff)
downloadgentoo-2-881fb20318f4bc9673f630f88d5a615955b5dbb1.tar.gz
gentoo-2-881fb20318f4bc9673f630f88d5a615955b5dbb1.tar.bz2
gentoo-2-881fb20318f4bc9673f630f88d5a615955b5dbb1.zip
Version bump for Rails 3.0.9.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.0.9.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index cd50a2a7b9dd..07849816896c 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.9 2011/05/01 14:12:22 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.10 2011/07/04 09:32:36 graaff Exp $
+
+*activemodel-3.0.9 (04 Jul 2011)
+
+ 04 Jul 2011; Hans de Graaff <graaff@gentoo.org> +activemodel-3.0.9.ebuild:
+ Version bump for Rails 3.0.9.
01 May 2011; Hans de Graaff <graaff@gentoo.org> -activemodel-3.0.3.ebuild,
-activemodel-3.0.3-r1.ebuild:
diff --git a/dev-ruby/activemodel/activemodel-3.0.9.ebuild b/dev-ruby/activemodel/activemodel-3.0.9.ebuild
new file mode 100644
index 000000000000..204fcf5e5ea9
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.0.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.0.9.ebuild,v 1.1 2011/07/04 09:32:36 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2
+ >=dev-ruby/i18n-0.5.0:0.5"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/ruby-debug
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}