summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-04-06 08:08:18 +0000
committerHans de Graaff <graaff@gentoo.org>2008-04-06 08:08:18 +0000
commit88bd2c21a1ee54231e92fee08c0c56646af3d897 (patch)
tree60f9888cf225387cfdb8cff1f940ae97d0443213 /dev-ruby
parentVersion bumped. (diff)
downloadgentoo-2-88bd2c21a1ee54231e92fee08c0c56646af3d897.tar.gz
gentoo-2-88bd2c21a1ee54231e92fee08c0c56646af3d897.tar.bz2
gentoo-2-88bd2c21a1ee54231e92fee08c0c56646af3d897.zip
Fix dependencies, quotation, closing #216379
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-opengl/ChangeLog9
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild16
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.32d.ebuild8
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild8
4 files changed, 24 insertions, 17 deletions
diff --git a/dev-ruby/ruby-opengl/ChangeLog b/dev-ruby/ruby-opengl/ChangeLog
index 7114769cab11..21f908c5d45e 100644
--- a/dev-ruby/ruby-opengl/ChangeLog
+++ b/dev-ruby/ruby-opengl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-opengl
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ChangeLog,v 1.16 2007/02/22 01:16:40 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ChangeLog,v 1.17 2008/04/06 08:08:18 graaff Exp $
+
+ 06 Apr 2008; Hans de Graaff <graaff@gentoo.org> ruby-opengl-0.32c.ebuild,
+ ruby-opengl-0.32d.ebuild, ruby-opengl-0.32g.ebuild:
+ Add missing dependencies to 32c version, fixing #216379; fix quotation of
+ variables
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild
index e3d35387d818..611665195891 100644
--- a/dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild,v 1.9 2005/04/24 10:50:53 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ruby-opengl-0.32c.ebuild,v 1.10 2008/04/06 08:08:18 graaff Exp $
inherit ruby eutils
USE_RUBY="ruby16 ruby18"
@@ -14,15 +14,17 @@ SLOT="0"
KEYWORDS="x86 ppc alpha ~sparc amd64"
IUSE=""
-DEPEND="virtual/ruby"
+DEPEND="virtual/ruby
+ virtual/opengl
+ virtual/glut"
S=${WORKDIR}/opengl-${PV}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-extconf-gentoo.diff
- epatch ${FILESDIR}/${P}-font-gentoo.diff
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-extconf-gentoo.diff"
+ epatch "${FILESDIR}/${P}-font-gentoo.diff"
}
src_compile() {
@@ -31,7 +33,7 @@ src_compile() {
}
src_install () {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc README.EUC ChangeLog
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.32d.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.32d.ebuild
index fbab3135b2c0..d9e12680e943 100644
--- a/dev-ruby/ruby-opengl/ruby-opengl-0.32d.ebuild
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.32d.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ruby-opengl-0.32d.ebuild,v 1.9 2006/01/13 19:17:38 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ruby-opengl-0.32d.ebuild,v 1.10 2008/04/06 08:08:18 graaff Exp $
inherit ruby
@@ -28,8 +28,8 @@ src_compile() {
}
src_install () {
- make -f Makefile.ogl DESTDIR=${D} install || die "install ogl failed"
- make -f Makefile.glut DESTDIR=${D} install || die "install glut failed"
+ make -f Makefile.ogl DESTDIR="${D}" install || die "install ogl failed"
+ make -f Makefile.glut DESTDIR="${D}" install || die "install glut failed"
dodoc README.EUC ChangeLog
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild
index 94a17bd7caf2..da42c699d6ac 100644
--- a/dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild,v 1.2 2006/05/12 19:58:12 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-opengl/ruby-opengl-0.32g.ebuild,v 1.3 2008/04/06 08:08:18 graaff Exp $
inherit ruby
@@ -28,8 +28,8 @@ src_compile() {
}
src_install () {
- make -f Makefile.ogl DESTDIR=${D} install || die "install ogl failed"
- make -f Makefile.glut DESTDIR=${D} install || die "install glut failed"
+ make -f Makefile.ogl DESTDIR="${D}" install || die "install ogl failed"
+ make -f Makefile.glut DESTDIR="${D}" install || die "install glut failed"
dodoc README.EUC ChangeLog